summaryrefslogtreecommitdiff
path: root/python-btlewrap.spec
diff options
context:
space:
mode:
authorCoprDistGit <copr-devel@lists.fedorahosted.org>2023-03-08 07:03:33 +0000
committerCoprDistGit <copr-devel@lists.fedorahosted.org>2023-03-08 07:03:33 +0000
commitb95256a1837950f642b3579c7c377c6829f65fe8 (patch)
tree5fc49dd0c9812f3c6f8e28b6c1506d7c8e5e3397 /python-btlewrap.spec
parent3586ae91f8831003be560f53060e99a108cfa13f (diff)
automatic import of python-btlewrap
Diffstat (limited to 'python-btlewrap.spec')
-rw-r--r--python-btlewrap.spec75
1 files changed, 75 insertions, 0 deletions
diff --git a/python-btlewrap.spec b/python-btlewrap.spec
new file mode 100644
index 0000000..43ea4b9
--- /dev/null
+++ b/python-btlewrap.spec
@@ -0,0 +1,75 @@
+%global _empty_manifest_terminate_build 0
+Name: python-btlewrap
+Version: 0.1.1
+Release: 1
+Summary: wrapper around different bluetooth low energy backends
+License: MIT
+URL: https://github.com/ChristianKuehnel/btlewrap
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/8b/08/fce5925b2aea22fbd715abf6039214bdd7214b34a26c3c9d59eafb46a51e/btlewrap-0.1.1.tar.gz
+BuildArch: noarch
+
+
+%description
+Bluetooth LowEnergy wrapper for different python backends. This gives you a nice API so that you can use different Bluetooth implementations on different platforms.
+This library was initially implemented as part of the `miflora <https://github.com/open-homeautomation/miflora>`_ library, but then refactored out, so that it can be used on other projects as well.
+
+%package -n python3-btlewrap
+Summary: wrapper around different bluetooth low energy backends
+Provides: python-btlewrap
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-btlewrap
+Bluetooth LowEnergy wrapper for different python backends. This gives you a nice API so that you can use different Bluetooth implementations on different platforms.
+This library was initially implemented as part of the `miflora <https://github.com/open-homeautomation/miflora>`_ library, but then refactored out, so that it can be used on other projects as well.
+
+%package help
+Summary: Development documents and examples for btlewrap
+Provides: python3-btlewrap-doc
+%description help
+Bluetooth LowEnergy wrapper for different python backends. This gives you a nice API so that you can use different Bluetooth implementations on different platforms.
+This library was initially implemented as part of the `miflora <https://github.com/open-homeautomation/miflora>`_ library, but then refactored out, so that it can be used on other projects as well.
+
+%prep
+%autosetup -n btlewrap-0.1.1
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-btlewrap -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Wed Mar 08 2023 Python_Bot <Python_Bot@openeuler.org> - 0.1.1-1
+- Package Spec generated