summaryrefslogtreecommitdiff
path: root/python-canonicalwebteam-store-api.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-canonicalwebteam-store-api.spec')
-rw-r--r--python-canonicalwebteam-store-api.spec156
1 files changed, 156 insertions, 0 deletions
diff --git a/python-canonicalwebteam-store-api.spec b/python-canonicalwebteam-store-api.spec
new file mode 100644
index 0000000..e9f1a19
--- /dev/null
+++ b/python-canonicalwebteam-store-api.spec
@@ -0,0 +1,156 @@
+%global _empty_manifest_terminate_build 0
+Name: python-canonicalwebteam-store-api
+Version: 4.1.0
+Release: 1
+Summary: please add a summary manually as the author left a blank one
+License: LGPL-3.0
+URL: https://pypi.org/project/canonicalwebteam-store-api/
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/a6/14/d765bd4c7ca2fa5887126ac35eb781c24f7e23d28a8e99e24bdd48c8c98e/canonicalwebteam_store_api-4.1.0.tar.gz
+BuildArch: noarch
+
+Requires: python3-coverage
+Requires: python3-pymacaroons
+Requires: python3-requests
+
+%description
+# Canonical Store Api - Python package
+
+[![Test live APIs](https://github.com/canonical-web-and-design/canonicalwebteam.store-api/workflows/Test%20live%20APIs/badge.svg)](https://github.com/canonical-web-and-design/canonicalwebteam.store-api/actions?query=workflow%3ATest%20live%20APIs)
+[![Tests](https://github.com/canonical-web-and-design/canonicalwebteam.store-api/workflows/Tests/badge.svg)](https://github.com/canonical-web-and-design/canonicalwebteam.store-api/actions?query=workflow%3A)
+[![Publish](https://github.com/canonical-web-and-design/canonicalwebteam.store-api/workflows/Publish/badge.svg)](https://github.com/canonical-web-and-design/canonicalwebteam.store-api/actions?query=workflow%3APublish)
+[![Code coverage](https://codecov.io/gh/canonical-web-and-design/canonicalwebteam.store-api/branch/main/graph/badge.svg)](https://codecov.io/gh/canonical-web-and-design/canonicalwebteam.store-api)
+
+## How to install
+
+To install this extension as a requirement in your project, you can use PIP:
+
+```bash
+pip install canonicalwebteam.store-api
+```
+
+See also the documentation for [pip install](https://pip.pypa.io/en/stable/reference/pip_install/).
+
+## Development
+
+The package leverages [poetry](https://poetry.eustace.io/) for dependency management.
+
+## Testing
+
+All tests can be run with `poetry run python3 -m unittest discover tests`.
+
+Note: You might have to do `poetry install` before runnning the command above.
+
+
+
+%package -n python3-canonicalwebteam-store-api
+Summary: please add a summary manually as the author left a blank one
+Provides: python-canonicalwebteam-store-api
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-canonicalwebteam-store-api
+# Canonical Store Api - Python package
+
+[![Test live APIs](https://github.com/canonical-web-and-design/canonicalwebteam.store-api/workflows/Test%20live%20APIs/badge.svg)](https://github.com/canonical-web-and-design/canonicalwebteam.store-api/actions?query=workflow%3ATest%20live%20APIs)
+[![Tests](https://github.com/canonical-web-and-design/canonicalwebteam.store-api/workflows/Tests/badge.svg)](https://github.com/canonical-web-and-design/canonicalwebteam.store-api/actions?query=workflow%3A)
+[![Publish](https://github.com/canonical-web-and-design/canonicalwebteam.store-api/workflows/Publish/badge.svg)](https://github.com/canonical-web-and-design/canonicalwebteam.store-api/actions?query=workflow%3APublish)
+[![Code coverage](https://codecov.io/gh/canonical-web-and-design/canonicalwebteam.store-api/branch/main/graph/badge.svg)](https://codecov.io/gh/canonical-web-and-design/canonicalwebteam.store-api)
+
+## How to install
+
+To install this extension as a requirement in your project, you can use PIP:
+
+```bash
+pip install canonicalwebteam.store-api
+```
+
+See also the documentation for [pip install](https://pip.pypa.io/en/stable/reference/pip_install/).
+
+## Development
+
+The package leverages [poetry](https://poetry.eustace.io/) for dependency management.
+
+## Testing
+
+All tests can be run with `poetry run python3 -m unittest discover tests`.
+
+Note: You might have to do `poetry install` before runnning the command above.
+
+
+
+%package help
+Summary: Development documents and examples for canonicalwebteam-store-api
+Provides: python3-canonicalwebteam-store-api-doc
+%description help
+# Canonical Store Api - Python package
+
+[![Test live APIs](https://github.com/canonical-web-and-design/canonicalwebteam.store-api/workflows/Test%20live%20APIs/badge.svg)](https://github.com/canonical-web-and-design/canonicalwebteam.store-api/actions?query=workflow%3ATest%20live%20APIs)
+[![Tests](https://github.com/canonical-web-and-design/canonicalwebteam.store-api/workflows/Tests/badge.svg)](https://github.com/canonical-web-and-design/canonicalwebteam.store-api/actions?query=workflow%3A)
+[![Publish](https://github.com/canonical-web-and-design/canonicalwebteam.store-api/workflows/Publish/badge.svg)](https://github.com/canonical-web-and-design/canonicalwebteam.store-api/actions?query=workflow%3APublish)
+[![Code coverage](https://codecov.io/gh/canonical-web-and-design/canonicalwebteam.store-api/branch/main/graph/badge.svg)](https://codecov.io/gh/canonical-web-and-design/canonicalwebteam.store-api)
+
+## How to install
+
+To install this extension as a requirement in your project, you can use PIP:
+
+```bash
+pip install canonicalwebteam.store-api
+```
+
+See also the documentation for [pip install](https://pip.pypa.io/en/stable/reference/pip_install/).
+
+## Development
+
+The package leverages [poetry](https://poetry.eustace.io/) for dependency management.
+
+## Testing
+
+All tests can be run with `poetry run python3 -m unittest discover tests`.
+
+Note: You might have to do `poetry install` before runnning the command above.
+
+
+
+%prep
+%autosetup -n canonicalwebteam-store-api-4.1.0
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-canonicalwebteam-store-api -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Mon May 15 2023 Python_Bot <Python_Bot@openeuler.org> - 4.1.0-1
+- Package Spec generated