summaryrefslogtreecommitdiff
path: root/python-chartmogul.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-chartmogul.spec')
-rw-r--r--python-chartmogul.spec80
1 files changed, 80 insertions, 0 deletions
diff --git a/python-chartmogul.spec b/python-chartmogul.spec
new file mode 100644
index 0000000..d1bec93
--- /dev/null
+++ b/python-chartmogul.spec
@@ -0,0 +1,80 @@
+%global _empty_manifest_terminate_build 0
+Name: python-chartmogul
+Version: 3.1.1
+Release: 1
+Summary: Python library for ChartMogul API.
+License: MIT
+URL: https://chartmogul.com
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/85/3a/9945661b91de7e4af39281c7c6bb52ff173a65cedd34b63661735eba867e/chartmogul-3.1.1.tar.gz
+BuildArch: noarch
+
+Requires: python3-requests
+Requires: python3-uritemplate
+Requires: python3-promise
+Requires: python3-marshmallow
+Requires: python3-future
+
+%description
+`See documentation on GitHub <https://github.com/chartmogul/chartmogul-python>`_
+
+
+%package -n python3-chartmogul
+Summary: Python library for ChartMogul API.
+Provides: python-chartmogul
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-chartmogul
+`See documentation on GitHub <https://github.com/chartmogul/chartmogul-python>`_
+
+
+%package help
+Summary: Development documents and examples for chartmogul
+Provides: python3-chartmogul-doc
+%description help
+`See documentation on GitHub <https://github.com/chartmogul/chartmogul-python>`_
+
+
+%prep
+%autosetup -n chartmogul-3.1.1
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-chartmogul -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Fri May 05 2023 Python_Bot <Python_Bot@openeuler.org> - 3.1.1-1
+- Package Spec generated