summaryrefslogtreecommitdiff
path: root/python-checkio-client.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-checkio-client.spec')
-rw-r--r--python-checkio-client.spec79
1 files changed, 79 insertions, 0 deletions
diff --git a/python-checkio-client.spec b/python-checkio-client.spec
new file mode 100644
index 0000000..de1b966
--- /dev/null
+++ b/python-checkio-client.spec
@@ -0,0 +1,79 @@
+%global _empty_manifest_terminate_build 0
+Name: python-checkio-client
+Version: 0.3.2
+Release: 1
+Summary: Command line interface for playing CheckiO games
+License: MIT License
+URL: https://github.com/CheckiO/checkio-client
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/32/f7/0184881868df69493ddb8715d7c1b5e14176515aaab66f10ea2cf03b25d5/checkio_client-0.3.2.tar.gz
+BuildArch: noarch
+
+Requires: python3-websockets
+Requires: python3-requests
+Requires: python3-aiohttp
+Requires: python3-aiohttp-cors
+Requires: python3-daemon
+Requires: python3-pid
+Requires: python3-checkio-json-serializer
+
+%description
+
+
+%package -n python3-checkio-client
+Summary: Command line interface for playing CheckiO games
+Provides: python-checkio-client
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-checkio-client
+
+
+%package help
+Summary: Development documents and examples for checkio-client
+Provides: python3-checkio-client-doc
+%description help
+
+
+%prep
+%autosetup -n checkio-client-0.3.2
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-checkio-client -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Wed May 10 2023 Python_Bot <Python_Bot@openeuler.org> - 0.3.2-1
+- Package Spec generated