summaryrefslogtreecommitdiff
path: root/python-churneval.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-churneval.spec')
-rw-r--r--python-churneval.spec469
1 files changed, 469 insertions, 0 deletions
diff --git a/python-churneval.spec b/python-churneval.spec
new file mode 100644
index 0000000..63a682b
--- /dev/null
+++ b/python-churneval.spec
@@ -0,0 +1,469 @@
+%global _empty_manifest_terminate_build 0
+Name: python-churneval
+Version: 1.3
+Release: 1
+Summary: churneval is a python package for evaluating churn models
+License: LICENSE.txt
+URL: https://pypi.org/project/churneval/
+Source0: https://mirrors.aliyun.com/pypi/web/packages/0d/b7/3df790382621d9510eb905cb0e6625913e94a027a08a33b9b1cfa7d0c135/churneval-1.3.tar.gz
+BuildArch: noarch
+
+Requires: python3-churneval
+Requires: python3-pandas
+Requires: python3-sklearn
+Requires: python3-matplotlib
+
+%description
+# Package "churneval"
+
+#### **Version:** 1.3
+
+#### **Author:** *Soumi De*
+
+#### **Maintained by:** Soumi De <<soumi.de@res.christuniversity.in>>
+
+#### **Description:**
+churneval is a package to evaluate models used in churn classification. The evaluation metrics include accuracy, sensitivity, specificity, precision, F1-score and top decile lift. The package also contains functions to plot lift curve and gain curve of a model.
+
+#### **License:** GPL-3
+
+#### **Date:** 12th November, 2021
+<br>
+
+___
+
+
+### **Function:**
+ get_performance_metrics Function that returns evaluation metrics
+
+___
+<br>
+
+### **Usage:**
+
+from churneval import get_performance_metrics
+
+get_performance_metrics(model_name, true_class, predicted_class, predicted_probs)
+
+### **Arguments:**
+* model_name: Abbreviated name of the churn model (in text)
+* true_class: A dataframe of true class labels with shape (n,1)
+* predicted_class: An array of binary predicted class with shape (n,)
+* predicted_probs: An array of predicted class probabilities with shape (n,)
+
+### **Returned Values:**
+
+A dataframe consisting of elements given below:
+* Model_Name: Abbreviated name of the churn model
+* Accuracy: Accuracy of churn model
+* Confusion Matrix: A 2X2 array representing confusion matrix
+* Precision: Precision value
+* Sensitivity: Sensitivity value
+* Specificity: Specificity value
+* F1-score: F1-score
+* ROC_score: Area under the curve
+* top_dec_lift: Top decile lift value
+
+<br>
+
+
+___
+
+### **Function:**
+ top_decile_lift Function that returns top decile lift of a sample
+
+___
+<br>
+
+### **Usage:**
+
+from churneval import top_decile_lift
+
+top_decile_lift(true_class, predicted_probs)
+
+### **Arguments:**
+* true_class: A dataframe of true class labels with shape (n,1)
+* predicted_probs: An array of predicted class probabilities with shape (n,)
+
+### **Returned Values:**
+
+* A float object with top decile lift value
+
+<br>
+
+
+___
+
+### **Function:**
+ lift_curve Function that plots lift curve of a model
+
+___
+<br>
+
+### **Usage:**
+
+from churneval import lift_curve
+
+lift_curve(true_class, predicted_probs)
+
+### **Arguments:**
+* true_class: A dataframe of true class labels with shape (n,1)
+* predicted_probs: An array of predicted class probabilities with shape (n,)
+
+### **Returned Values:**
+
+* A plot that shows lift curve
+ * x-axis: Proportion of data
+ * y-axis: Lift of the model
+
+<br>
+
+
+___
+
+### **Function:**
+ gain_curve Function that plots gain curve of a model
+
+___
+<br>
+
+### **Usage:**
+
+from churneval import gain_curve
+
+gain_curve(true_class, predicted_probs)
+
+### **Arguments:**
+* true_class: A dataframe of true class labels with shape (n,1)
+* predicted_probs: An array of predicted class probabilities with shape (n,)
+
+### **Returned Values:**
+
+* A plot that shows lift curve
+ * x-axis: Proportion of data
+ * y-axis: Gain of the model
+
+
+
+
+
+%package -n python3-churneval
+Summary: churneval is a python package for evaluating churn models
+Provides: python-churneval
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-churneval
+# Package "churneval"
+
+#### **Version:** 1.3
+
+#### **Author:** *Soumi De*
+
+#### **Maintained by:** Soumi De <<soumi.de@res.christuniversity.in>>
+
+#### **Description:**
+churneval is a package to evaluate models used in churn classification. The evaluation metrics include accuracy, sensitivity, specificity, precision, F1-score and top decile lift. The package also contains functions to plot lift curve and gain curve of a model.
+
+#### **License:** GPL-3
+
+#### **Date:** 12th November, 2021
+<br>
+
+___
+
+
+### **Function:**
+ get_performance_metrics Function that returns evaluation metrics
+
+___
+<br>
+
+### **Usage:**
+
+from churneval import get_performance_metrics
+
+get_performance_metrics(model_name, true_class, predicted_class, predicted_probs)
+
+### **Arguments:**
+* model_name: Abbreviated name of the churn model (in text)
+* true_class: A dataframe of true class labels with shape (n,1)
+* predicted_class: An array of binary predicted class with shape (n,)
+* predicted_probs: An array of predicted class probabilities with shape (n,)
+
+### **Returned Values:**
+
+A dataframe consisting of elements given below:
+* Model_Name: Abbreviated name of the churn model
+* Accuracy: Accuracy of churn model
+* Confusion Matrix: A 2X2 array representing confusion matrix
+* Precision: Precision value
+* Sensitivity: Sensitivity value
+* Specificity: Specificity value
+* F1-score: F1-score
+* ROC_score: Area under the curve
+* top_dec_lift: Top decile lift value
+
+<br>
+
+
+___
+
+### **Function:**
+ top_decile_lift Function that returns top decile lift of a sample
+
+___
+<br>
+
+### **Usage:**
+
+from churneval import top_decile_lift
+
+top_decile_lift(true_class, predicted_probs)
+
+### **Arguments:**
+* true_class: A dataframe of true class labels with shape (n,1)
+* predicted_probs: An array of predicted class probabilities with shape (n,)
+
+### **Returned Values:**
+
+* A float object with top decile lift value
+
+<br>
+
+
+___
+
+### **Function:**
+ lift_curve Function that plots lift curve of a model
+
+___
+<br>
+
+### **Usage:**
+
+from churneval import lift_curve
+
+lift_curve(true_class, predicted_probs)
+
+### **Arguments:**
+* true_class: A dataframe of true class labels with shape (n,1)
+* predicted_probs: An array of predicted class probabilities with shape (n,)
+
+### **Returned Values:**
+
+* A plot that shows lift curve
+ * x-axis: Proportion of data
+ * y-axis: Lift of the model
+
+<br>
+
+
+___
+
+### **Function:**
+ gain_curve Function that plots gain curve of a model
+
+___
+<br>
+
+### **Usage:**
+
+from churneval import gain_curve
+
+gain_curve(true_class, predicted_probs)
+
+### **Arguments:**
+* true_class: A dataframe of true class labels with shape (n,1)
+* predicted_probs: An array of predicted class probabilities with shape (n,)
+
+### **Returned Values:**
+
+* A plot that shows lift curve
+ * x-axis: Proportion of data
+ * y-axis: Gain of the model
+
+
+
+
+
+%package help
+Summary: Development documents and examples for churneval
+Provides: python3-churneval-doc
+%description help
+# Package "churneval"
+
+#### **Version:** 1.3
+
+#### **Author:** *Soumi De*
+
+#### **Maintained by:** Soumi De <<soumi.de@res.christuniversity.in>>
+
+#### **Description:**
+churneval is a package to evaluate models used in churn classification. The evaluation metrics include accuracy, sensitivity, specificity, precision, F1-score and top decile lift. The package also contains functions to plot lift curve and gain curve of a model.
+
+#### **License:** GPL-3
+
+#### **Date:** 12th November, 2021
+<br>
+
+___
+
+
+### **Function:**
+ get_performance_metrics Function that returns evaluation metrics
+
+___
+<br>
+
+### **Usage:**
+
+from churneval import get_performance_metrics
+
+get_performance_metrics(model_name, true_class, predicted_class, predicted_probs)
+
+### **Arguments:**
+* model_name: Abbreviated name of the churn model (in text)
+* true_class: A dataframe of true class labels with shape (n,1)
+* predicted_class: An array of binary predicted class with shape (n,)
+* predicted_probs: An array of predicted class probabilities with shape (n,)
+
+### **Returned Values:**
+
+A dataframe consisting of elements given below:
+* Model_Name: Abbreviated name of the churn model
+* Accuracy: Accuracy of churn model
+* Confusion Matrix: A 2X2 array representing confusion matrix
+* Precision: Precision value
+* Sensitivity: Sensitivity value
+* Specificity: Specificity value
+* F1-score: F1-score
+* ROC_score: Area under the curve
+* top_dec_lift: Top decile lift value
+
+<br>
+
+
+___
+
+### **Function:**
+ top_decile_lift Function that returns top decile lift of a sample
+
+___
+<br>
+
+### **Usage:**
+
+from churneval import top_decile_lift
+
+top_decile_lift(true_class, predicted_probs)
+
+### **Arguments:**
+* true_class: A dataframe of true class labels with shape (n,1)
+* predicted_probs: An array of predicted class probabilities with shape (n,)
+
+### **Returned Values:**
+
+* A float object with top decile lift value
+
+<br>
+
+
+___
+
+### **Function:**
+ lift_curve Function that plots lift curve of a model
+
+___
+<br>
+
+### **Usage:**
+
+from churneval import lift_curve
+
+lift_curve(true_class, predicted_probs)
+
+### **Arguments:**
+* true_class: A dataframe of true class labels with shape (n,1)
+* predicted_probs: An array of predicted class probabilities with shape (n,)
+
+### **Returned Values:**
+
+* A plot that shows lift curve
+ * x-axis: Proportion of data
+ * y-axis: Lift of the model
+
+<br>
+
+
+___
+
+### **Function:**
+ gain_curve Function that plots gain curve of a model
+
+___
+<br>
+
+### **Usage:**
+
+from churneval import gain_curve
+
+gain_curve(true_class, predicted_probs)
+
+### **Arguments:**
+* true_class: A dataframe of true class labels with shape (n,1)
+* predicted_probs: An array of predicted class probabilities with shape (n,)
+
+### **Returned Values:**
+
+* A plot that shows lift curve
+ * x-axis: Proportion of data
+ * y-axis: Gain of the model
+
+
+
+
+
+%prep
+%autosetup -n churneval-1.3
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-churneval -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Tue Jun 20 2023 Python_Bot <Python_Bot@openeuler.org> - 1.3-1
+- Package Spec generated