summaryrefslogtreecommitdiff
path: root/python-ckanext-dc-serve.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-ckanext-dc-serve.spec')
-rw-r--r--python-ckanext-dc-serve.spec16
1 files changed, 8 insertions, 8 deletions
diff --git a/python-ckanext-dc-serve.spec b/python-ckanext-dc-serve.spec
index 2a31972..327f3d2 100644
--- a/python-ckanext-dc-serve.spec
+++ b/python-ckanext-dc-serve.spec
@@ -5,7 +5,7 @@ Release: 1
Summary: Serve DC files via GET requests on DCOR
License: AGPLv3+
URL: https://github.com/DCOR-dev/ckanext-dc_serve
-Source0: https://mirrors.nju.edu.cn/pypi/web/packages/70/e0/c1b981a2bc7c734765f25de0db8c7b3b1db7a656dd7a3b3a26ce2a1816e5/ckanext-dc_serve-0.11.0.tar.gz
+Source0: https://mirrors.aliyun.com/pypi/web/packages/70/e0/c1b981a2bc7c734765f25de0db8c7b3b1db7a656dd7a3b3a26ce2a1816e5/ckanext-dc_serve-0.11.0.tar.gz
BuildArch: noarch
Requires: python3-dclab
@@ -69,7 +69,7 @@ This plugin implements:
jobs for all resources (if not already done)
%prep
-%autosetup -n ckanext-dc-serve-0.11.0
+%autosetup -n ckanext-dc_serve-0.11.0
%build
%py3_build
@@ -83,20 +83,20 @@ if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
- find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+ find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
- find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+ find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
- find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+ find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
- find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+ find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
- find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+ find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
@@ -109,5 +109,5 @@ mv %{buildroot}/doclist.lst .
%{_docdir}/*
%changelog
-* Tue May 30 2023 Python_Bot <Python_Bot@openeuler.org> - 0.11.0-1
+* Thu Jun 08 2023 Python_Bot <Python_Bot@openeuler.org> - 0.11.0-1
- Package Spec generated