summaryrefslogtreecommitdiff
path: root/python-clahe.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-clahe.spec')
-rw-r--r--python-clahe.spec81
1 files changed, 81 insertions, 0 deletions
diff --git a/python-clahe.spec b/python-clahe.spec
new file mode 100644
index 0000000..3695bac
--- /dev/null
+++ b/python-clahe.spec
@@ -0,0 +1,81 @@
+%global _empty_manifest_terminate_build 0
+Name: python-clahe
+Version: 0.1
+Release: 1
+Summary: Exact contrast-limited adaptive histogram equalization
+License: MIT
+URL: https://github.com/anntzer/clahe
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/ce/9b/92d75f5fa56caf9e97803f147c26922df57791ddf134bfa0bea3bc74a118/clahe-0.1.tar.gz
+BuildArch: noarch
+
+
+%description
+As usual, install using pip:
+ $ pip install . # from source checkout
+ $ pip install git+https://github.com/anntzer/clahe # from Github
+Run tests with pytest.
+
+%package -n python3-clahe
+Summary: Exact contrast-limited adaptive histogram equalization
+Provides: python-clahe
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-clahe
+As usual, install using pip:
+ $ pip install . # from source checkout
+ $ pip install git+https://github.com/anntzer/clahe # from Github
+Run tests with pytest.
+
+%package help
+Summary: Development documents and examples for clahe
+Provides: python3-clahe-doc
+%description help
+As usual, install using pip:
+ $ pip install . # from source checkout
+ $ pip install git+https://github.com/anntzer/clahe # from Github
+Run tests with pytest.
+
+%prep
+%autosetup -n clahe-0.1
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-clahe -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Fri May 05 2023 Python_Bot <Python_Bot@openeuler.org> - 0.1-1
+- Package Spec generated