summaryrefslogtreecommitdiff
path: root/python-clappform.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-clappform.spec')
-rw-r--r--python-clappform.spec123
1 files changed, 123 insertions, 0 deletions
diff --git a/python-clappform.spec b/python-clappform.spec
new file mode 100644
index 0000000..edb57e6
--- /dev/null
+++ b/python-clappform.spec
@@ -0,0 +1,123 @@
+%global _empty_manifest_terminate_build 0
+Name: python-clappform
+Version: 2.6.0
+Release: 1
+Summary: Clappform Python API wrapper
+License: MIT License
+URL: https://pypi.org/project/clappform/
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/fe/ac/2db75cc66ec72b35653b5b1d46dbf876bc9545397f77b8ff571edf66d086/clappform-2.6.0.tar.gz
+BuildArch: noarch
+
+Requires: python3-requests
+Requires: python3-Cerberus
+Requires: python3-pandas
+
+%description
+# Clappform
+**Clappform** is a wrapper for a Clappform B.V. API written in Python.
+
+```python
+>>> from clappform import Clappform
+>>> c = Clappform("https://app.clappform.com", "j.doe@clappform.com", "S3cr3tP4ssw0rd!")
+>>> apps = c.get_apps()
+>>> for app in apps:
+... print(app.name)
+'Clappform'
+'Default'
+```
+
+Clappform allows you to interact with the Clappform API for a given domain. For many of the resources that the Clappform API provides the simple ``get``, ``create``, ``update`` and ``delete`` methods can be used. Authentication is done transparently, so there is no need to manually authenticate.
+
+## Developer interface is available on [Read The Docs](https://clappform.readthedocs.io)
+
+
+%package -n python3-clappform
+Summary: Clappform Python API wrapper
+Provides: python-clappform
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-clappform
+# Clappform
+**Clappform** is a wrapper for a Clappform B.V. API written in Python.
+
+```python
+>>> from clappform import Clappform
+>>> c = Clappform("https://app.clappform.com", "j.doe@clappform.com", "S3cr3tP4ssw0rd!")
+>>> apps = c.get_apps()
+>>> for app in apps:
+... print(app.name)
+'Clappform'
+'Default'
+```
+
+Clappform allows you to interact with the Clappform API for a given domain. For many of the resources that the Clappform API provides the simple ``get``, ``create``, ``update`` and ``delete`` methods can be used. Authentication is done transparently, so there is no need to manually authenticate.
+
+## Developer interface is available on [Read The Docs](https://clappform.readthedocs.io)
+
+
+%package help
+Summary: Development documents and examples for clappform
+Provides: python3-clappform-doc
+%description help
+# Clappform
+**Clappform** is a wrapper for a Clappform B.V. API written in Python.
+
+```python
+>>> from clappform import Clappform
+>>> c = Clappform("https://app.clappform.com", "j.doe@clappform.com", "S3cr3tP4ssw0rd!")
+>>> apps = c.get_apps()
+>>> for app in apps:
+... print(app.name)
+'Clappform'
+'Default'
+```
+
+Clappform allows you to interact with the Clappform API for a given domain. For many of the resources that the Clappform API provides the simple ``get``, ``create``, ``update`` and ``delete`` methods can be used. Authentication is done transparently, so there is no need to manually authenticate.
+
+## Developer interface is available on [Read The Docs](https://clappform.readthedocs.io)
+
+
+%prep
+%autosetup -n clappform-2.6.0
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-clappform -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Wed May 10 2023 Python_Bot <Python_Bot@openeuler.org> - 2.6.0-1
+- Package Spec generated