summaryrefslogtreecommitdiff
path: root/python-clashogram.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-clashogram.spec')
-rw-r--r--python-clashogram.spec103
1 files changed, 103 insertions, 0 deletions
diff --git a/python-clashogram.spec b/python-clashogram.spec
new file mode 100644
index 0000000..a4920f3
--- /dev/null
+++ b/python-clashogram.spec
@@ -0,0 +1,103 @@
+%global _empty_manifest_terminate_build 0
+Name: python-clashogram
+Version: 0.9.1
+Release: 1
+Summary: Clash of Clans war moniting for telegram channels.
+License: MIT License
+URL: https://github.com/mehdisadeghi/clashogram
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/25/ae/a97508be0606060f215ba00d8ebe32816cf7a2d833329361ce3ebbe01965/clashogram-0.9.1.tar.gz
+BuildArch: noarch
+
+Requires: python3-requests
+Requires: python3-jdatetime
+Requires: python3-pytz
+Requires: python3-dateutil
+Requires: python3-click
+Requires: python3-babel
+Requires: python3-pytest
+
+%description
+Clash of Clans war moniting for telegram channels.
+ NOTE: Clash of Clans API data is always 10 minutes behind the game
+ events. This is not a bug in this program.
+``clashogram`` monitors your clan's warlog and posts the following
+messages to a Telegram channel:
+1. Preparation started (with clans and players information)
+2. War started
+3. New attacks (with details)
+4. War over
+
+%package -n python3-clashogram
+Summary: Clash of Clans war moniting for telegram channels.
+Provides: python-clashogram
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-clashogram
+Clash of Clans war moniting for telegram channels.
+ NOTE: Clash of Clans API data is always 10 minutes behind the game
+ events. This is not a bug in this program.
+``clashogram`` monitors your clan's warlog and posts the following
+messages to a Telegram channel:
+1. Preparation started (with clans and players information)
+2. War started
+3. New attacks (with details)
+4. War over
+
+%package help
+Summary: Development documents and examples for clashogram
+Provides: python3-clashogram-doc
+%description help
+Clash of Clans war moniting for telegram channels.
+ NOTE: Clash of Clans API data is always 10 minutes behind the game
+ events. This is not a bug in this program.
+``clashogram`` monitors your clan's warlog and posts the following
+messages to a Telegram channel:
+1. Preparation started (with clans and players information)
+2. War started
+3. New attacks (with details)
+4. War over
+
+%prep
+%autosetup -n clashogram-0.9.1
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-clashogram -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Mon May 29 2023 Python_Bot <Python_Bot@openeuler.org> - 0.9.1-1
+- Package Spec generated