summaryrefslogtreecommitdiff
path: root/python-cltk.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-cltk.spec')
-rw-r--r--python-cltk.spec95
1 files changed, 95 insertions, 0 deletions
diff --git a/python-cltk.spec b/python-cltk.spec
new file mode 100644
index 0000000..827f4d5
--- /dev/null
+++ b/python-cltk.spec
@@ -0,0 +1,95 @@
+%global _empty_manifest_terminate_build 0
+Name: python-cltk
+Version: 1.1.6
+Release: 1
+Summary: The Classical Language Toolkit
+License: MIT
+URL: http://cltk.org
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/04/ab/379fab7333f5cc1d1162e2270f5a5a2dfa15412c1c4c6c0d63773155814c/cltk-1.1.6.tar.gz
+BuildArch: noarch
+
+Requires: python3-gitpython
+Requires: python3-requests
+Requires: python3-tqdm
+Requires: python3-gensim
+Requires: python3-boltons
+Requires: python3-greek-accentuation
+Requires: python3-Levenshtein
+Requires: python3-stanza
+Requires: python3-nltk
+Requires: python3-stringcase
+Requires: python3-spacy
+Requires: python3-PyYAML
+Requires: python3-scikit-learn
+Requires: python3-scipy
+
+%description
+For the CLTK's latest version:
+ $ pip install cltk
+For more information, see `Installation docs <https://docs.cltk.org/en/latest/installation.html>`_ or, to install from source, `Development <https://docs.cltk.org/en/latest/development.html>`_.
+Pre-1.0 software remains available on the `branch v0.1.x <https://github.com/cltk/cltk/tree/v0.1.x>`_ and docs at `<https://legacy.cltk.org>`_. Install it with ``pip install "cltk<1.0"``.
+
+%package -n python3-cltk
+Summary: The Classical Language Toolkit
+Provides: python-cltk
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-cltk
+For the CLTK's latest version:
+ $ pip install cltk
+For more information, see `Installation docs <https://docs.cltk.org/en/latest/installation.html>`_ or, to install from source, `Development <https://docs.cltk.org/en/latest/development.html>`_.
+Pre-1.0 software remains available on the `branch v0.1.x <https://github.com/cltk/cltk/tree/v0.1.x>`_ and docs at `<https://legacy.cltk.org>`_. Install it with ``pip install "cltk<1.0"``.
+
+%package help
+Summary: Development documents and examples for cltk
+Provides: python3-cltk-doc
+%description help
+For the CLTK's latest version:
+ $ pip install cltk
+For more information, see `Installation docs <https://docs.cltk.org/en/latest/installation.html>`_ or, to install from source, `Development <https://docs.cltk.org/en/latest/development.html>`_.
+Pre-1.0 software remains available on the `branch v0.1.x <https://github.com/cltk/cltk/tree/v0.1.x>`_ and docs at `<https://legacy.cltk.org>`_. Install it with ``pip install "cltk<1.0"``.
+
+%prep
+%autosetup -n cltk-1.1.6
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-cltk -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Fri May 05 2023 Python_Bot <Python_Bot@openeuler.org> - 1.1.6-1
+- Package Spec generated