summaryrefslogtreecommitdiff
path: root/python-coco.spec
diff options
context:
space:
mode:
authorCoprDistGit <infra@openeuler.org>2023-05-10 06:35:50 +0000
committerCoprDistGit <infra@openeuler.org>2023-05-10 06:35:50 +0000
commit086e23713c2b751508c63ddf03d65f59a135552d (patch)
treea4daf517398faa6a8773e1a7e879c0a31f43fa94 /python-coco.spec
parent8a63d402de02f057639b4db21d2c2ed06c5473fd (diff)
automatic import of python-coco
Diffstat (limited to 'python-coco.spec')
-rw-r--r--python-coco.spec87
1 files changed, 87 insertions, 0 deletions
diff --git a/python-coco.spec b/python-coco.spec
new file mode 100644
index 0000000..04a7547
--- /dev/null
+++ b/python-coco.spec
@@ -0,0 +1,87 @@
+%global _empty_manifest_terminate_build 0
+Name: python-coco
+Version: 0.4.0
+Release: 1
+Summary: battery health & more
+License: UNKNOWN
+URL: https://github.com/cwoebker/coco
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/88/3f/01432b8e521e59693f02db6eed24fc45601efe3308d96bb46ed5546c1913/coco-0.4.0.tar.gz
+BuildArch: noarch
+
+
+%description
+A minimalistic utility to monitor and log battery health & more.
+
+Homepage and documentation: github.com/cwoebker/coco
+
+Copyright (c) 2012, Cecil Woebker.
+License: BSD (see LICENSE for details)
+
+%package -n python3-coco
+Summary: battery health & more
+Provides: python-coco
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-coco
+A minimalistic utility to monitor and log battery health & more.
+
+Homepage and documentation: github.com/cwoebker/coco
+
+Copyright (c) 2012, Cecil Woebker.
+License: BSD (see LICENSE for details)
+
+%package help
+Summary: Development documents and examples for coco
+Provides: python3-coco-doc
+%description help
+A minimalistic utility to monitor and log battery health & more.
+
+Homepage and documentation: github.com/cwoebker/coco
+
+Copyright (c) 2012, Cecil Woebker.
+License: BSD (see LICENSE for details)
+
+%prep
+%autosetup -n coco-0.4.0
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-coco -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Wed May 10 2023 Python_Bot <Python_Bot@openeuler.org> - 0.4.0-1
+- Package Spec generated