summaryrefslogtreecommitdiff
path: root/python-colcon-recursive-crawl.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-colcon-recursive-crawl.spec')
-rw-r--r--python-colcon-recursive-crawl.spec73
1 files changed, 73 insertions, 0 deletions
diff --git a/python-colcon-recursive-crawl.spec b/python-colcon-recursive-crawl.spec
new file mode 100644
index 0000000..c37c7da
--- /dev/null
+++ b/python-colcon-recursive-crawl.spec
@@ -0,0 +1,73 @@
+%global _empty_manifest_terminate_build 0
+Name: python-colcon-recursive-crawl
+Version: 0.2.1
+Release: 1
+Summary: Extension for colcon to recursively crawl for packages.
+License: Apache License, Version 2.0
+URL: https://colcon.readthedocs.io
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/c3/9e/bc1935dc532af90b802ed16cf0a1f5f858275e49d775895fca5161fc9910/colcon-recursive-crawl-0.2.1.tar.gz
+BuildArch: noarch
+
+Requires: python3-colcon-core
+
+%description
+An extension for `colcon-core <https://github.com/colcon/colcon-core>`_ to recursively crawl for packages.
+
+%package -n python3-colcon-recursive-crawl
+Summary: Extension for colcon to recursively crawl for packages.
+Provides: python-colcon-recursive-crawl
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-colcon-recursive-crawl
+An extension for `colcon-core <https://github.com/colcon/colcon-core>`_ to recursively crawl for packages.
+
+%package help
+Summary: Development documents and examples for colcon-recursive-crawl
+Provides: python3-colcon-recursive-crawl-doc
+%description help
+An extension for `colcon-core <https://github.com/colcon/colcon-core>`_ to recursively crawl for packages.
+
+%prep
+%autosetup -n colcon-recursive-crawl-0.2.1
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-colcon-recursive-crawl -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Thu Mar 09 2023 Python_Bot <Python_Bot@openeuler.org> - 0.2.1-1
+- Package Spec generated