summaryrefslogtreecommitdiff
path: root/python-config.spec
diff options
context:
space:
mode:
authorCoprDistGit <infra@openeuler.org>2023-04-10 13:30:21 +0000
committerCoprDistGit <infra@openeuler.org>2023-04-10 13:30:21 +0000
commitfabfa0e2934a7da28b2a368be2d66a51e0409e69 (patch)
tree2e43bdfea8c9fcf9a47becd7a3ed311fa552d2ce /python-config.spec
parent41f1fced1b2a43c82b4b7b3b679d670a1d8bc442 (diff)
automatic import of python-config
Diffstat (limited to 'python-config.spec')
-rw-r--r--python-config.spec81
1 files changed, 81 insertions, 0 deletions
diff --git a/python-config.spec b/python-config.spec
new file mode 100644
index 0000000..ddb9469
--- /dev/null
+++ b/python-config.spec
@@ -0,0 +1,81 @@
+%global _empty_manifest_terminate_build 0
+Name: python-config
+Version: 0.5.1
+Release: 1
+Summary: A hierarchical, easy-to-use, powerful configuration module for Python
+License: Copyright (C) 2004-2020 by Vinay Sajip. All Rights Reserved. See LICENSE for license.
+URL: http://docs.red-dove.com/cfg/python.html
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/b3/a9/c44e131d60a97a7615e5d6b4f998e373df51a8e385d89fb37232d7b7e5ec/config-0.5.1.zip
+BuildArch: noarch
+
+
+%description
+This module allows a hierarchical configuration scheme with support for mappings and sequences, cross-references between one part of the configuration and another, the ability to flexibly access real Python objects without full-blown eval(), an include facility, simple expression evaluation and the ability to change, save, cascade and merge configurations. Interfaces easily with environment variables and command-line options.
+
+
+
+
+%package -n python3-config
+Summary: A hierarchical, easy-to-use, powerful configuration module for Python
+Provides: python-config
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-config
+This module allows a hierarchical configuration scheme with support for mappings and sequences, cross-references between one part of the configuration and another, the ability to flexibly access real Python objects without full-blown eval(), an include facility, simple expression evaluation and the ability to change, save, cascade and merge configurations. Interfaces easily with environment variables and command-line options.
+
+
+
+
+%package help
+Summary: Development documents and examples for config
+Provides: python3-config-doc
+%description help
+This module allows a hierarchical configuration scheme with support for mappings and sequences, cross-references between one part of the configuration and another, the ability to flexibly access real Python objects without full-blown eval(), an include facility, simple expression evaluation and the ability to change, save, cascade and merge configurations. Interfaces easily with environment variables and command-line options.
+
+
+
+
+%prep
+%autosetup -n config-0.5.1
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-config -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Mon Apr 10 2023 Python_Bot <Python_Bot@openeuler.org> - 0.5.1-1
+- Package Spec generated