summaryrefslogtreecommitdiff
path: root/python-configure.spec
diff options
context:
space:
mode:
authorCoprDistGit <infra@openeuler.org>2023-06-20 04:57:02 +0000
committerCoprDistGit <infra@openeuler.org>2023-06-20 04:57:02 +0000
commit786301d459e95541aabe2a8248316bba59c55c13 (patch)
treedaf19032ea8d45ad7bdfbd8437ebf2b68af49449 /python-configure.spec
parentcb61e77098dc42251d3ddc1453805aa046cae0ab (diff)
automatic import of python-configureopeneuler20.03
Diffstat (limited to 'python-configure.spec')
-rw-r--r--python-configure.spec105
1 files changed, 105 insertions, 0 deletions
diff --git a/python-configure.spec b/python-configure.spec
new file mode 100644
index 0000000..0f66d8d
--- /dev/null
+++ b/python-configure.spec
@@ -0,0 +1,105 @@
+%global _empty_manifest_terminate_build 0
+Name: python-configure
+Version: 0.5
+Release: 1
+Summary: configuration toolkit based on YAML
+License: UNKNOWN
+URL: https://github.com/andreypopp/configure
+Source0: https://mirrors.aliyun.com/pypi/web/packages/14/59/030ec95d0b03836593e743da8650854dd32ddde54d304d0a417367a4a94f/configure-0.5.tar.gz
+BuildArch: noarch
+
+
+%description
+YAML configuration library which provides:
+
+ * interpolation for string configuration values
+
+ * configuration inheritance
+
+ * configuration composition
+
+ * object level configuration (like construct this object by calling some
+ function with some arguments)
+
+Development takes place at https://github.com/andreypopp/configure
+
+%package -n python3-configure
+Summary: configuration toolkit based on YAML
+Provides: python-configure
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-configure
+YAML configuration library which provides:
+
+ * interpolation for string configuration values
+
+ * configuration inheritance
+
+ * configuration composition
+
+ * object level configuration (like construct this object by calling some
+ function with some arguments)
+
+Development takes place at https://github.com/andreypopp/configure
+
+%package help
+Summary: Development documents and examples for configure
+Provides: python3-configure-doc
+%description help
+YAML configuration library which provides:
+
+ * interpolation for string configuration values
+
+ * configuration inheritance
+
+ * configuration composition
+
+ * object level configuration (like construct this object by calling some
+ function with some arguments)
+
+Development takes place at https://github.com/andreypopp/configure
+
+%prep
+%autosetup -n configure-0.5
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-configure -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Tue Jun 20 2023 Python_Bot <Python_Bot@openeuler.org> - 0.5-1
+- Package Spec generated