summaryrefslogtreecommitdiff
path: root/python-cookiejar.spec
diff options
context:
space:
mode:
authorCoprDistGit <infra@openeuler.org>2023-05-10 07:33:50 +0000
committerCoprDistGit <infra@openeuler.org>2023-05-10 07:33:50 +0000
commita5ef7b85a9ee367fb19609a38bd80db32e70e4cd (patch)
tree61e2eb9e93d705f4024858485a3b7ddc1ace95fc /python-cookiejar.spec
parent46e0bf76713421aaa73de34aac5e3a6cdee74df1 (diff)
automatic import of python-cookiejar
Diffstat (limited to 'python-cookiejar.spec')
-rw-r--r--python-cookiejar.spec87
1 files changed, 87 insertions, 0 deletions
diff --git a/python-cookiejar.spec b/python-cookiejar.spec
new file mode 100644
index 0000000..41dd5a6
--- /dev/null
+++ b/python-cookiejar.spec
@@ -0,0 +1,87 @@
+%global _empty_manifest_terminate_build 0
+Name: python-cookiejar
+Version: 0.0.3
+Release: 1
+Summary: Cookiecutter templates discovery and management.
+License: MIT
+URL: https://github.com/fcurella/cookiejar
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/ee/ed/9f12c2ff7678dc2219b925b191dea0ab9f4ae28f885180c864ca5ce48f9a/cookiejar-0.0.3.tar.gz
+BuildArch: noarch
+
+Requires: python3-argparse
+Requires: python3-pager
+Requires: python3-cookiecutter
+
+%description
+Cookiecutter templates discovery and management.
+Usage::
+ $ pip install cookiejar
+ $ cookiejar create <templatename> [options]
+Will use `cookiecutter <https://github.com/audreyr/cookiecutter>`_ to create a new package from the template.
+
+%package -n python3-cookiejar
+Summary: Cookiecutter templates discovery and management.
+Provides: python-cookiejar
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-cookiejar
+Cookiecutter templates discovery and management.
+Usage::
+ $ pip install cookiejar
+ $ cookiejar create <templatename> [options]
+Will use `cookiecutter <https://github.com/audreyr/cookiecutter>`_ to create a new package from the template.
+
+%package help
+Summary: Development documents and examples for cookiejar
+Provides: python3-cookiejar-doc
+%description help
+Cookiecutter templates discovery and management.
+Usage::
+ $ pip install cookiejar
+ $ cookiejar create <templatename> [options]
+Will use `cookiecutter <https://github.com/audreyr/cookiecutter>`_ to create a new package from the template.
+
+%prep
+%autosetup -n cookiejar-0.0.3
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-cookiejar -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Wed May 10 2023 Python_Bot <Python_Bot@openeuler.org> - 0.0.3-1
+- Package Spec generated