summaryrefslogtreecommitdiff
path: root/python-country-currencies.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-country-currencies.spec')
-rw-r--r--python-country-currencies.spec75
1 files changed, 75 insertions, 0 deletions
diff --git a/python-country-currencies.spec b/python-country-currencies.spec
new file mode 100644
index 0000000..d8b14a0
--- /dev/null
+++ b/python-country-currencies.spec
@@ -0,0 +1,75 @@
+%global _empty_manifest_terminate_build 0
+Name: python-country-currencies
+Version: 0.2
+Release: 1
+Summary: mapping of ISO-3166 country codes to their respective currencies
+License: MIT/X
+URL: UNKNOWN
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/5e/ff/e18c2a3ec1595fd28bddd2491d35e10756898c3514b981e23bd0c9c98e46/country-currencies-0.2.tar.gz
+BuildArch: noarch
+
+
+%description
+country-currencies is a Python module that provides a mapping of ISO-3166
+country codes to the currencies used.
+
+%package -n python3-country-currencies
+Summary: mapping of ISO-3166 country codes to their respective currencies
+Provides: python-country-currencies
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-country-currencies
+country-currencies is a Python module that provides a mapping of ISO-3166
+country codes to the currencies used.
+
+%package help
+Summary: Development documents and examples for country-currencies
+Provides: python3-country-currencies-doc
+%description help
+country-currencies is a Python module that provides a mapping of ISO-3166
+country codes to the currencies used.
+
+%prep
+%autosetup -n country-currencies-0.2
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-country-currencies -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Fri May 05 2023 Python_Bot <Python_Bot@openeuler.org> - 0.2-1
+- Package Spec generated