summaryrefslogtreecommitdiff
path: root/python-cube-simulator.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-cube-simulator.spec')
-rw-r--r--python-cube-simulator.spec73
1 files changed, 73 insertions, 0 deletions
diff --git a/python-cube-simulator.spec b/python-cube-simulator.spec
new file mode 100644
index 0000000..27b1ccb
--- /dev/null
+++ b/python-cube-simulator.spec
@@ -0,0 +1,73 @@
+%global _empty_manifest_terminate_build 0
+Name: python-cube-simulator
+Version: 2.3.7
+Release: 1
+Summary: A money flow simuator
+License: MIT
+URL: http://github.com/CubeConsumerServivesPvtLtd/simulator
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/79/64/48a0bef2e905057f34b4d8673272d65174206b13b6a49badd0e7f123e750/cube-simulator-2.3.7.tar.gz
+BuildArch: noarch
+
+Requires: python3-dateutil
+
+%description
+
+
+%package -n python3-cube-simulator
+Summary: A money flow simuator
+Provides: python-cube-simulator
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-cube-simulator
+
+
+%package help
+Summary: Development documents and examples for cube-simulator
+Provides: python3-cube-simulator-doc
+%description help
+
+
+%prep
+%autosetup -n cube-simulator-2.3.7
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-cube-simulator -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Mon May 29 2023 Python_Bot <Python_Bot@openeuler.org> - 2.3.7-1
+- Package Spec generated