summaryrefslogtreecommitdiff
path: root/python-cuenca-validations.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-cuenca-validations.spec')
-rw-r--r--python-cuenca-validations.spec97
1 files changed, 97 insertions, 0 deletions
diff --git a/python-cuenca-validations.spec b/python-cuenca-validations.spec
new file mode 100644
index 0000000..50576fd
--- /dev/null
+++ b/python-cuenca-validations.spec
@@ -0,0 +1,97 @@
+%global _empty_manifest_terminate_build 0
+Name: python-cuenca-validations
+Version: 0.11.18
+Release: 1
+Summary: Cuenca common validations
+License: MIT License
+URL: https://github.com/cuenca-mx/cuenca-validations
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/e5/99/adbd49bac4091865b9b37c0e31cdf294b78206769521953ec9b4b65f1b9e/cuenca_validations-0.11.18.tar.gz
+BuildArch: noarch
+
+Requires: python3-clabe
+Requires: python3-pydantic[email]
+Requires: python3-dateutil
+Requires: python3-dataclasses
+
+%description
+# Cuenca - validations
+
+[![test](https://github.com/cuenca-mx/cuenca-validations/workflows/test/badge.svg)](https://github.com/cuenca-mx/cuenca-validations/actions?query=workflow%3Atest)
+[![codecov](https://codecov.io/gh/cuenca-mx/cuenca-validations/branch/master/graph/badge.svg)](https://codecov.io/gh/cuenca-mx/cuenca-validations)
+[![PyPI](https://img.shields.io/pypi/v/cuenca-validations.svg)](https://pypi.org/project/cuenca-validations/)
+
+Shared validations library across multiple Cuenca projects
+
+
+%package -n python3-cuenca-validations
+Summary: Cuenca common validations
+Provides: python-cuenca-validations
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-cuenca-validations
+# Cuenca - validations
+
+[![test](https://github.com/cuenca-mx/cuenca-validations/workflows/test/badge.svg)](https://github.com/cuenca-mx/cuenca-validations/actions?query=workflow%3Atest)
+[![codecov](https://codecov.io/gh/cuenca-mx/cuenca-validations/branch/master/graph/badge.svg)](https://codecov.io/gh/cuenca-mx/cuenca-validations)
+[![PyPI](https://img.shields.io/pypi/v/cuenca-validations.svg)](https://pypi.org/project/cuenca-validations/)
+
+Shared validations library across multiple Cuenca projects
+
+
+%package help
+Summary: Development documents and examples for cuenca-validations
+Provides: python3-cuenca-validations-doc
+%description help
+# Cuenca - validations
+
+[![test](https://github.com/cuenca-mx/cuenca-validations/workflows/test/badge.svg)](https://github.com/cuenca-mx/cuenca-validations/actions?query=workflow%3Atest)
+[![codecov](https://codecov.io/gh/cuenca-mx/cuenca-validations/branch/master/graph/badge.svg)](https://codecov.io/gh/cuenca-mx/cuenca-validations)
+[![PyPI](https://img.shields.io/pypi/v/cuenca-validations.svg)](https://pypi.org/project/cuenca-validations/)
+
+Shared validations library across multiple Cuenca projects
+
+
+%prep
+%autosetup -n cuenca-validations-0.11.18
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-cuenca-validations -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Sun Apr 23 2023 Python_Bot <Python_Bot@openeuler.org> - 0.11.18-1
+- Package Spec generated