summaryrefslogtreecommitdiff
path: root/python-currency-symbols.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-currency-symbols.spec')
-rw-r--r--python-currency-symbols.spec261
1 files changed, 261 insertions, 0 deletions
diff --git a/python-currency-symbols.spec b/python-currency-symbols.spec
new file mode 100644
index 0000000..f308425
--- /dev/null
+++ b/python-currency-symbols.spec
@@ -0,0 +1,261 @@
+%global _empty_manifest_terminate_build 0
+Name: python-currency-symbols
+Version: 2.0.3
+Release: 1
+Summary: Get currency symbol by currency code
+License: MIT License
+URL: https://github.com/arshadkazmi42/currency-symbols
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/35/09/aaafc15ae4412897085addcd3445411d82a2dc069cc17e3c393295fe9aa2/currency-symbols-2.0.3.tar.gz
+BuildArch: noarch
+
+
+%description
+# currency-symbols :money_with_wings:
+
+[![Build](https://github.com/arshadkazmi42/currency-symbols/actions/workflows/pytest.yml/badge.svg)](https://github.com/arshadkazmi42/currency-symbols/actions/workflows/pytest.yml)
+[![Downloads](https://img.shields.io/pypi/dm/currency-symbols.svg)](https://pypi.org/project/currency-symbols/)
+[![Repo Size](https://img.shields.io/github/languages/code-size/arshadkazmi42/currency-symbols.svg)](https://github.com/arshadkazmi42/currency-symbols)
+[![LICENSE](https://img.shields.io/pypi/l/currency-symbols.svg)](https://pypi.org/project/currency-symbols/)
+[![Version](https://img.shields.io/pypi/v/currency-symbols.svg)](https://pypi.org/project/currency-symbols/)
+[![Last Commit](https://img.shields.io/github/last-commit/arshadkazmi42/currency-symbols.svg)](https://github.com/arshadkazmi42/currency-symbols)
+
+Get currency symbol by currency code `eg: USD -> $`
+
+## References
+[ISO 4217 - Currency Codes](https://www.iso.org/iso-4217-currency-codes.html)
+
+## Installation
+
+```
+$ pip3 install currency-symbols
+```
+
+## Usage
+
+```python
+from currency_symbols import CurrencySymbols
+
+dollarSymbol = CurrencySymbols.get_symbol('USD')
+print(dollarSymbol)
+
+# Output:
+# $
+
+euroSymbol = CurrencySymbols.get_symbol('EUR')
+print(euroSymbol)
+
+# Output:
+# €
+
+britishPoundSymbol = CurrencySymbols.get_symbol('GBP')
+print(britishPoundSymbol)
+
+# Output:
+# £
+
+bitcoinSymbol = CurrencySymbols.get_symbol('BTC')
+print(bitcoinSymbol)
+
+# Output:
+# ฿
+```
+
+## Contributing
+
+Interested in contributing to this project?
+You can log any issues or suggestion related to this library [here](https://github.com/arshadkazmi42/currency-symbols/issues/new)
+
+Read our contributing [guide](https://github.com/arshadkazmi42/currency-symbols/blob/master/CONTRIBUTING.md) on getting started with contributing to the codebase
+
+
+## Credits
+
+Inspired by work of [@bengourley](https://github.com/bengourley) on [currency-symbol-map](https://github.com/bengourley/currency-symbol-map#readme)
+
+
+
+
+%package -n python3-currency-symbols
+Summary: Get currency symbol by currency code
+Provides: python-currency-symbols
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-currency-symbols
+# currency-symbols :money_with_wings:
+
+[![Build](https://github.com/arshadkazmi42/currency-symbols/actions/workflows/pytest.yml/badge.svg)](https://github.com/arshadkazmi42/currency-symbols/actions/workflows/pytest.yml)
+[![Downloads](https://img.shields.io/pypi/dm/currency-symbols.svg)](https://pypi.org/project/currency-symbols/)
+[![Repo Size](https://img.shields.io/github/languages/code-size/arshadkazmi42/currency-symbols.svg)](https://github.com/arshadkazmi42/currency-symbols)
+[![LICENSE](https://img.shields.io/pypi/l/currency-symbols.svg)](https://pypi.org/project/currency-symbols/)
+[![Version](https://img.shields.io/pypi/v/currency-symbols.svg)](https://pypi.org/project/currency-symbols/)
+[![Last Commit](https://img.shields.io/github/last-commit/arshadkazmi42/currency-symbols.svg)](https://github.com/arshadkazmi42/currency-symbols)
+
+Get currency symbol by currency code `eg: USD -> $`
+
+## References
+[ISO 4217 - Currency Codes](https://www.iso.org/iso-4217-currency-codes.html)
+
+## Installation
+
+```
+$ pip3 install currency-symbols
+```
+
+## Usage
+
+```python
+from currency_symbols import CurrencySymbols
+
+dollarSymbol = CurrencySymbols.get_symbol('USD')
+print(dollarSymbol)
+
+# Output:
+# $
+
+euroSymbol = CurrencySymbols.get_symbol('EUR')
+print(euroSymbol)
+
+# Output:
+# €
+
+britishPoundSymbol = CurrencySymbols.get_symbol('GBP')
+print(britishPoundSymbol)
+
+# Output:
+# £
+
+bitcoinSymbol = CurrencySymbols.get_symbol('BTC')
+print(bitcoinSymbol)
+
+# Output:
+# ฿
+```
+
+## Contributing
+
+Interested in contributing to this project?
+You can log any issues or suggestion related to this library [here](https://github.com/arshadkazmi42/currency-symbols/issues/new)
+
+Read our contributing [guide](https://github.com/arshadkazmi42/currency-symbols/blob/master/CONTRIBUTING.md) on getting started with contributing to the codebase
+
+
+## Credits
+
+Inspired by work of [@bengourley](https://github.com/bengourley) on [currency-symbol-map](https://github.com/bengourley/currency-symbol-map#readme)
+
+
+
+
+%package help
+Summary: Development documents and examples for currency-symbols
+Provides: python3-currency-symbols-doc
+%description help
+# currency-symbols :money_with_wings:
+
+[![Build](https://github.com/arshadkazmi42/currency-symbols/actions/workflows/pytest.yml/badge.svg)](https://github.com/arshadkazmi42/currency-symbols/actions/workflows/pytest.yml)
+[![Downloads](https://img.shields.io/pypi/dm/currency-symbols.svg)](https://pypi.org/project/currency-symbols/)
+[![Repo Size](https://img.shields.io/github/languages/code-size/arshadkazmi42/currency-symbols.svg)](https://github.com/arshadkazmi42/currency-symbols)
+[![LICENSE](https://img.shields.io/pypi/l/currency-symbols.svg)](https://pypi.org/project/currency-symbols/)
+[![Version](https://img.shields.io/pypi/v/currency-symbols.svg)](https://pypi.org/project/currency-symbols/)
+[![Last Commit](https://img.shields.io/github/last-commit/arshadkazmi42/currency-symbols.svg)](https://github.com/arshadkazmi42/currency-symbols)
+
+Get currency symbol by currency code `eg: USD -> $`
+
+## References
+[ISO 4217 - Currency Codes](https://www.iso.org/iso-4217-currency-codes.html)
+
+## Installation
+
+```
+$ pip3 install currency-symbols
+```
+
+## Usage
+
+```python
+from currency_symbols import CurrencySymbols
+
+dollarSymbol = CurrencySymbols.get_symbol('USD')
+print(dollarSymbol)
+
+# Output:
+# $
+
+euroSymbol = CurrencySymbols.get_symbol('EUR')
+print(euroSymbol)
+
+# Output:
+# €
+
+britishPoundSymbol = CurrencySymbols.get_symbol('GBP')
+print(britishPoundSymbol)
+
+# Output:
+# £
+
+bitcoinSymbol = CurrencySymbols.get_symbol('BTC')
+print(bitcoinSymbol)
+
+# Output:
+# ฿
+```
+
+## Contributing
+
+Interested in contributing to this project?
+You can log any issues or suggestion related to this library [here](https://github.com/arshadkazmi42/currency-symbols/issues/new)
+
+Read our contributing [guide](https://github.com/arshadkazmi42/currency-symbols/blob/master/CONTRIBUTING.md) on getting started with contributing to the codebase
+
+
+## Credits
+
+Inspired by work of [@bengourley](https://github.com/bengourley) on [currency-symbol-map](https://github.com/bengourley/currency-symbol-map#readme)
+
+
+
+
+%prep
+%autosetup -n currency-symbols-2.0.3
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-currency-symbols -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Fri May 05 2023 Python_Bot <Python_Bot@openeuler.org> - 2.0.3-1
+- Package Spec generated