summaryrefslogtreecommitdiff
path: root/python-d2lvalence.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-d2lvalence.spec')
-rw-r--r--python-d2lvalence.spec16
1 files changed, 8 insertions, 8 deletions
diff --git a/python-d2lvalence.spec b/python-d2lvalence.spec
index 3ec783a..f301efe 100644
--- a/python-d2lvalence.spec
+++ b/python-d2lvalence.spec
@@ -5,7 +5,7 @@ Release: 1
Summary: D2LValence client library for Python.
License: Apache 2.0
URL: http://www.desire2learn.com/r/valencehome
-Source0: https://mirrors.nju.edu.cn/pypi/web/packages/ba/9d/85bf12435b307738d9dca30732851d16a2ae4f017b628451b896f53aba78/d2lvalence-1.2.2.tar.gz
+Source0: https://mirrors.aliyun.com/pypi/web/packages/ba/9d/85bf12435b307738d9dca30732851d16a2ae4f017b628451b896f53aba78/d2lvalence-1.2.2.tar.gz
BuildArch: noarch
Requires: python3-future
@@ -30,7 +30,7 @@ Provides: python3-D2LValence-doc
%prep
-%autosetup -n D2LValence-1.2.2
+%autosetup -n d2lvalence-1.2.2
%build
%py3_build
@@ -44,20 +44,20 @@ if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
- find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+ find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
- find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+ find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
- find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+ find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
- find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+ find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
- find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+ find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
@@ -70,5 +70,5 @@ mv %{buildroot}/doclist.lst .
%{_docdir}/*
%changelog
-* Tue May 30 2023 Python_Bot <Python_Bot@openeuler.org> - 1.2.2-1
+* Fri Jun 09 2023 Python_Bot <Python_Bot@openeuler.org> - 1.2.2-1
- Package Spec generated