summaryrefslogtreecommitdiff
path: root/python-dartcms.spec
diff options
context:
space:
mode:
authorCoprDistGit <infra@openeuler.org>2023-05-15 05:57:21 +0000
committerCoprDistGit <infra@openeuler.org>2023-05-15 05:57:21 +0000
commit588a3c9d67428ae85c4e0e29617521249c2f81f5 (patch)
treefcb7fa98e025513dd9a005d4760227dfe1ddf684 /python-dartcms.spec
parentabc08fc9685080b813065e26d7ef738abefc18d0 (diff)
automatic import of python-dartcms
Diffstat (limited to 'python-dartcms.spec')
-rw-r--r--python-dartcms.spec72
1 files changed, 72 insertions, 0 deletions
diff --git a/python-dartcms.spec b/python-dartcms.spec
new file mode 100644
index 0000000..a40fff1
--- /dev/null
+++ b/python-dartcms.spec
@@ -0,0 +1,72 @@
+%global _empty_manifest_terminate_build 0
+Name: python-dartcms
+Version: 0.2.1
+Release: 1
+Summary: DartCMS - open-source content management system for Django
+License: MIT License
+URL: https://github.com/astrikov-d/dartcms
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/9f/92/15f9cd58d13147d188cde0f745241343b413839d0ce56465d1763a51dcfb/dartcms-0.2.1.tar.gz
+BuildArch: noarch
+
+
+%description
+DartCMS is an open-source content management system based on the popular Django Framework. It is friendly for developers and end-users.
+
+%package -n python3-dartcms
+Summary: DartCMS - open-source content management system for Django
+Provides: python-dartcms
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-dartcms
+DartCMS is an open-source content management system based on the popular Django Framework. It is friendly for developers and end-users.
+
+%package help
+Summary: Development documents and examples for dartcms
+Provides: python3-dartcms-doc
+%description help
+DartCMS is an open-source content management system based on the popular Django Framework. It is friendly for developers and end-users.
+
+%prep
+%autosetup -n dartcms-0.2.1
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-dartcms -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Mon May 15 2023 Python_Bot <Python_Bot@openeuler.org> - 0.2.1-1
+- Package Spec generated