summaryrefslogtreecommitdiff
path: root/python-darts.spec
diff options
context:
space:
mode:
authorCoprDistGit <infra@openeuler.org>2023-04-25 09:15:23 +0000
committerCoprDistGit <infra@openeuler.org>2023-04-25 09:15:23 +0000
commitd6e1cfadf0ff3f8b2cf6bb77f5a4cd1de8ff8654 (patch)
tree2d6b6a6f1ddf8f59d9b4b60dc5a8947b52a0952d /python-darts.spec
parent8d09030a6ea53a03f4a389622280eedf9bd91427 (diff)
automatic import of python-dartsopeneuler20.03
Diffstat (limited to 'python-darts.spec')
-rw-r--r--python-darts.spec15
1 files changed, 8 insertions, 7 deletions
diff --git a/python-darts.spec b/python-darts.spec
index 0e039ef..a619139 100644
--- a/python-darts.spec
+++ b/python-darts.spec
@@ -1,11 +1,11 @@
%global _empty_manifest_terminate_build 0
Name: python-darts
-Version: 0.23.1
+Version: 0.24.0
Release: 1
Summary: A python library for easy manipulation and forecasting of time series.
License: Apache License 2.0
URL: https://unit8co.github.io/darts/
-Source0: https://mirrors.nju.edu.cn/pypi/web/packages/08/91/a560e7756161f81f92155537518c6fb8c47e762eb153330073cd588d8bca/darts-0.23.1.tar.gz
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/91/c6/e1786d323f0b68de0e42873bfc81d78208bd5cc8588f4ee16e86cc017556/darts-0.24.0.tar.gz
BuildArch: noarch
Requires: python3-catboost
@@ -30,6 +30,7 @@ Requires: python3-tqdm
Requires: python3-xarray
Requires: python3-xgboost
Requires: python3-pytorch-lightning
+Requires: python3-tensorboardX
Requires: python3-torch
%description
@@ -177,7 +178,7 @@ series.plot()
* **PyTorch Lightning Support:** All deep learning models are implemented using PyTorch Lightning,
supporting among other things custom callbacks, GPUs/TPUs training and custom trainers.
* **Filtering Models:** Darts offers three filtering models: `KalmanFilter`, `GaussianProcessFilter`,
- and `MovingAverage`, which allow to filter time series, and in some cases obtain probabilistic
+ and `MovingAverageFilter`, which allow to filter time series, and in some cases obtain probabilistic
inferences of the underlying states/values.
* **Datasets** The `darts.datasets` submodule contains some popular time series datasets for rapid
and reproducible experimentation.
@@ -336,7 +337,7 @@ series.plot()
* **PyTorch Lightning Support:** All deep learning models are implemented using PyTorch Lightning,
supporting among other things custom callbacks, GPUs/TPUs training and custom trainers.
* **Filtering Models:** Darts offers three filtering models: `KalmanFilter`, `GaussianProcessFilter`,
- and `MovingAverage`, which allow to filter time series, and in some cases obtain probabilistic
+ and `MovingAverageFilter`, which allow to filter time series, and in some cases obtain probabilistic
inferences of the underlying states/values.
* **Datasets** The `darts.datasets` submodule contains some popular time series datasets for rapid
and reproducible experimentation.
@@ -492,7 +493,7 @@ series.plot()
* **PyTorch Lightning Support:** All deep learning models are implemented using PyTorch Lightning,
supporting among other things custom callbacks, GPUs/TPUs training and custom trainers.
* **Filtering Models:** Darts offers three filtering models: `KalmanFilter`, `GaussianProcessFilter`,
- and `MovingAverage`, which allow to filter time series, and in some cases obtain probabilistic
+ and `MovingAverageFilter`, which allow to filter time series, and in some cases obtain probabilistic
inferences of the underlying states/values.
* **Datasets** The `darts.datasets` submodule contains some popular time series datasets for rapid
and reproducible experimentation.
@@ -501,7 +502,7 @@ Here's a breakdown of the forecasting models currently implemented in Darts. We
on bringing more models and features.
%prep
-%autosetup -n darts-0.23.1
+%autosetup -n darts-0.24.0
%build
%py3_build
@@ -541,5 +542,5 @@ mv %{buildroot}/doclist.lst .
%{_docdir}/*
%changelog
-* Tue Apr 11 2023 Python_Bot <Python_Bot@openeuler.org> - 0.23.1-1
+* Tue Apr 25 2023 Python_Bot <Python_Bot@openeuler.org> - 0.24.0-1
- Package Spec generated