summaryrefslogtreecommitdiff
path: root/python-dask-yarn.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-dask-yarn.spec')
-rw-r--r--python-dask-yarn.spec94
1 files changed, 94 insertions, 0 deletions
diff --git a/python-dask-yarn.spec b/python-dask-yarn.spec
new file mode 100644
index 0000000..6746c54
--- /dev/null
+++ b/python-dask-yarn.spec
@@ -0,0 +1,94 @@
+%global _empty_manifest_terminate_build 0
+Name: python-dask-yarn
+Version: 0.9
+Release: 1
+Summary: Deploy dask clusters on Apache YARN
+License: BSD
+URL: https://pypi.org/project/dask-yarn/
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/d8/87/2ae81ed3fb7d057ce520208b5e0aa185472cdc111ea98ea4b9c5a1efcaec/dask-yarn-0.9.tar.gz
+BuildArch: noarch
+
+Requires: python3-dask
+Requires: python3-distributed
+Requires: python3-skein
+Requires: python3-grpcio
+
+%description
+|travis| |readthedocs| |pypi| |conda|
+Dask-Yarn deploys Dask on `YARN
+<https://hadoop.apache.org/docs/current/hadoop-yarn/hadoop-yarn-site/YARN.html>`_
+clusters, such as are found in traditional Hadoop installations. Dask-Yarn
+provides an easy interface to quickly start, stop, and scale Dask clusters
+natively from Python.
+See `the documentation <http://yarn.dask.org>`_ for more information.
+
+%package -n python3-dask-yarn
+Summary: Deploy dask clusters on Apache YARN
+Provides: python-dask-yarn
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-dask-yarn
+|travis| |readthedocs| |pypi| |conda|
+Dask-Yarn deploys Dask on `YARN
+<https://hadoop.apache.org/docs/current/hadoop-yarn/hadoop-yarn-site/YARN.html>`_
+clusters, such as are found in traditional Hadoop installations. Dask-Yarn
+provides an easy interface to quickly start, stop, and scale Dask clusters
+natively from Python.
+See `the documentation <http://yarn.dask.org>`_ for more information.
+
+%package help
+Summary: Development documents and examples for dask-yarn
+Provides: python3-dask-yarn-doc
+%description help
+|travis| |readthedocs| |pypi| |conda|
+Dask-Yarn deploys Dask on `YARN
+<https://hadoop.apache.org/docs/current/hadoop-yarn/hadoop-yarn-site/YARN.html>`_
+clusters, such as are found in traditional Hadoop installations. Dask-Yarn
+provides an easy interface to quickly start, stop, and scale Dask clusters
+natively from Python.
+See `the documentation <http://yarn.dask.org>`_ for more information.
+
+%prep
+%autosetup -n dask-yarn-0.9
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-dask-yarn -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Fri May 05 2023 Python_Bot <Python_Bot@openeuler.org> - 0.9-1
+- Package Spec generated