summaryrefslogtreecommitdiff
path: root/python-dc-client.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-dc-client.spec')
-rw-r--r--python-dc-client.spec82
1 files changed, 82 insertions, 0 deletions
diff --git a/python-dc-client.spec b/python-dc-client.spec
new file mode 100644
index 0000000..5e30c2c
--- /dev/null
+++ b/python-dc-client.spec
@@ -0,0 +1,82 @@
+%global _empty_manifest_terminate_build 0
+Name: python-dc-client
+Version: 0.0.113
+Release: 1
+Summary: Data Catalog Client
+License: MIT
+URL: https://github.com/stonezhong/DataManager/tree/master/client/dc_client
+Source0: https://mirrors.aliyun.com/pypi/web/packages/b0/eb/bf7fea80c6d6716380c98f9b475e58c26221b1b239caf21d2a36f978aeeb/dc-client-0.0.113.tar.gz
+BuildArch: noarch
+
+Requires: python3-requests
+
+%description
+Blah...
+
+
+
+
+%package -n python3-dc-client
+Summary: Data Catalog Client
+Provides: python-dc-client
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-dc-client
+Blah...
+
+
+
+
+%package help
+Summary: Development documents and examples for dc-client
+Provides: python3-dc-client-doc
+%description help
+Blah...
+
+
+
+
+%prep
+%autosetup -n dc-client-0.0.113
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-dc-client -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Tue Jun 20 2023 Python_Bot <Python_Bot@openeuler.org> - 0.0.113-1
+- Package Spec generated