summaryrefslogtreecommitdiff
path: root/python-ddtrace.spec
diff options
context:
space:
mode:
authorCoprDistGit <infra@openeuler.org>2023-04-21 11:31:51 +0000
committerCoprDistGit <infra@openeuler.org>2023-04-21 11:31:51 +0000
commit9ff3532789d8cbfeed206dee4816c12bb73dba72 (patch)
treee387a262dc819cd551fb5c6bda5a247e26ab84a2 /python-ddtrace.spec
parent8eee16fcbd442881332b6ded63171646907794ff (diff)
automatic import of python-ddtraceopeneuler20.03
Diffstat (limited to 'python-ddtrace.spec')
-rw-r--r--python-ddtrace.spec169
1 files changed, 169 insertions, 0 deletions
diff --git a/python-ddtrace.spec b/python-ddtrace.spec
new file mode 100644
index 0000000..70e826b
--- /dev/null
+++ b/python-ddtrace.spec
@@ -0,0 +1,169 @@
+%global _empty_manifest_terminate_build 0
+Name: python-ddtrace
+Version: 1.12.0
+Release: 1
+Summary: Datadog APM client library
+License: BSD
+URL: https://github.com/DataDog/dd-trace-py
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/da/f6/50702ead2bc8070d7ee4b526ef494e265e258313a94631498efee6bcf68a/ddtrace-1.12.0.tar.gz
+
+Requires: python3-ddsketch
+Requires: python3-packaging
+Requires: python3-tenacity
+Requires: python3-cattrs
+Requires: python3-six
+Requires: python3-typing-extensions
+Requires: python3-jsonschema
+Requires: python3-xmltodict
+Requires: python3-envier
+Requires: python3-dead-bytecode
+Requires: python3-enum34
+Requires: python3-typing
+Requires: python3-pathlib2
+Requires: python3-protobuf
+Requires: python3-ipaddress
+Requires: python3-pep562
+Requires: python3-importlib-metadata
+Requires: python3-funcsigs
+Requires: python3-attrs
+Requires: python3-contextlib2
+Requires: python3-bytecode
+Requires: python3-protobuf
+Requires: python3-bytecode
+Requires: python3-bytecode
+Requires: python3-attrs
+Requires: python3-protobuf
+Requires: python3-opentelemetry-api
+Requires: python3-bytecode
+Requires: python3-opentracing
+
+%description
+# dd-trace-py
+
+`ddtrace` is Datadog's tracing library for Python. It is used to trace requests
+as they flow across web servers, databases and microservices so that developers
+have great visibility into bottlenecks and troublesome requests.
+
+## Getting Started
+
+For a basic product overview, installation and quick start, check out our
+[setup documentation][setup docs].
+
+For more advanced usage and configuration, check out our [API
+documentation][api docs].
+
+For descriptions of terminology used in APM, take a look at the [official
+documentation][visualization docs].
+
+[setup docs]: https://docs.datadoghq.com/tracing/setup/python/
+[api docs]: https://ddtrace.readthedocs.io/
+[visualization docs]: https://docs.datadoghq.com/tracing/visualization/
+
+
+
+
+%package -n python3-ddtrace
+Summary: Datadog APM client library
+Provides: python-ddtrace
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+BuildRequires: python3-cffi
+BuildRequires: gcc
+BuildRequires: gdb
+%description -n python3-ddtrace
+# dd-trace-py
+
+`ddtrace` is Datadog's tracing library for Python. It is used to trace requests
+as they flow across web servers, databases and microservices so that developers
+have great visibility into bottlenecks and troublesome requests.
+
+## Getting Started
+
+For a basic product overview, installation and quick start, check out our
+[setup documentation][setup docs].
+
+For more advanced usage and configuration, check out our [API
+documentation][api docs].
+
+For descriptions of terminology used in APM, take a look at the [official
+documentation][visualization docs].
+
+[setup docs]: https://docs.datadoghq.com/tracing/setup/python/
+[api docs]: https://ddtrace.readthedocs.io/
+[visualization docs]: https://docs.datadoghq.com/tracing/visualization/
+
+
+
+
+%package help
+Summary: Development documents and examples for ddtrace
+Provides: python3-ddtrace-doc
+%description help
+# dd-trace-py
+
+`ddtrace` is Datadog's tracing library for Python. It is used to trace requests
+as they flow across web servers, databases and microservices so that developers
+have great visibility into bottlenecks and troublesome requests.
+
+## Getting Started
+
+For a basic product overview, installation and quick start, check out our
+[setup documentation][setup docs].
+
+For more advanced usage and configuration, check out our [API
+documentation][api docs].
+
+For descriptions of terminology used in APM, take a look at the [official
+documentation][visualization docs].
+
+[setup docs]: https://docs.datadoghq.com/tracing/setup/python/
+[api docs]: https://ddtrace.readthedocs.io/
+[visualization docs]: https://docs.datadoghq.com/tracing/visualization/
+
+
+
+
+%prep
+%autosetup -n ddtrace-1.12.0
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-ddtrace -f filelist.lst
+%dir %{python3_sitearch}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Fri Apr 21 2023 Python_Bot <Python_Bot@openeuler.org> - 1.12.0-1
+- Package Spec generated