summaryrefslogtreecommitdiff
path: root/python-decrunch.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-decrunch.spec')
-rw-r--r--python-decrunch.spec72
1 files changed, 72 insertions, 0 deletions
diff --git a/python-decrunch.spec b/python-decrunch.spec
new file mode 100644
index 0000000..4048234
--- /dev/null
+++ b/python-decrunch.spec
@@ -0,0 +1,72 @@
+%global _empty_manifest_terminate_build 0
+Name: python-decrunch
+Version: 0.4.0.post1
+Release: 1
+Summary: Python wrapper around Crunch DXTc decompressor
+License: zlib/libpng License
+URL: https://github.com/HearthSim/decrunch/
+Source0: https://mirrors.aliyun.com/pypi/web/packages/b6/42/5a2f9f25f1bd0f9326d8eb2454812d7d09663602c090da9d290cdd908426/decrunch-0.4.0.post1.tar.gz
+BuildArch: noarch
+
+
+%description
+
+
+%package -n python3-decrunch
+Summary: Python wrapper around Crunch DXTc decompressor
+Provides: python-decrunch
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-decrunch
+
+
+%package help
+Summary: Development documents and examples for decrunch
+Provides: python3-decrunch-doc
+%description help
+
+
+%prep
+%autosetup -n decrunch-0.4.0.post1
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-decrunch -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Tue Jun 20 2023 Python_Bot <Python_Bot@openeuler.org> - 0.4.0.post1-1
+- Package Spec generated