summaryrefslogtreecommitdiff
path: root/python-demisto-py.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-demisto-py.spec')
-rw-r--r--python-demisto-py.spec17
1 files changed, 10 insertions, 7 deletions
diff --git a/python-demisto-py.spec b/python-demisto-py.spec
index 5d48568..fcb2098 100644
--- a/python-demisto-py.spec
+++ b/python-demisto-py.spec
@@ -1,11 +1,11 @@
%global _empty_manifest_terminate_build 0
Name: python-demisto-py
-Version: 3.2.8
+Version: 3.2.9
Release: 1
Summary: A Python library for the Demisto API
License: Apache Software License
URL: https://github.com/demisto/demisto-py
-Source0: https://mirrors.nju.edu.cn/pypi/web/packages/3f/3c/6e2d55a842893f3db676debe5b69a1a6aacaf84064491ae557c8f3cd3571/demisto-py-3.2.8.tar.gz
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/a3/04/b2369aa8944eeab76a081de7daca22d420138a75c3bba16dbdda13b85da5/demisto-py-3.2.9.tar.gz
BuildArch: noarch
Requires: python3-certifi
@@ -36,13 +36,14 @@ Follow these instructions to generate your Demisto API Key.
1. In Demisto, navigate to **Settings > API Keys**.
2. Click the **Generate Your Key** button.
-To avoid hard coding configurations in your code, it is possible to specify configruation params
+To avoid hard coding configurations in your code, it is possible to specify configuration params
as the following environment variables (env variables will be used if parameters are not specified):
* DEMISTO_BASE_URL
* DEMISTO_API_KEY
* DEMISTO_USERNAME
* DEMISTO_PASSWORD
+* DEMISTO_HTTP_HEADERS (must be in the form of: header1=value1,header2=value2,header3=value3,...headerN=valueN)
* DEMISTO_VERIFY_SSL (true/false. Default: true)
* XSIAM_AUTH_ID (for Cortex XSIAM only. If set, Cortex XSIAM API will be used)
* SSL_CERT_FILE (specify an alternate certificate bundle)
@@ -273,13 +274,14 @@ Follow these instructions to generate your Demisto API Key.
1. In Demisto, navigate to **Settings > API Keys**.
2. Click the **Generate Your Key** button.
-To avoid hard coding configurations in your code, it is possible to specify configruation params
+To avoid hard coding configurations in your code, it is possible to specify configuration params
as the following environment variables (env variables will be used if parameters are not specified):
* DEMISTO_BASE_URL
* DEMISTO_API_KEY
* DEMISTO_USERNAME
* DEMISTO_PASSWORD
+* DEMISTO_HTTP_HEADERS (must be in the form of: header1=value1,header2=value2,header3=value3,...headerN=valueN)
* DEMISTO_VERIFY_SSL (true/false. Default: true)
* XSIAM_AUTH_ID (for Cortex XSIAM only. If set, Cortex XSIAM API will be used)
* SSL_CERT_FILE (specify an alternate certificate bundle)
@@ -507,13 +509,14 @@ Follow these instructions to generate your Demisto API Key.
1. In Demisto, navigate to **Settings > API Keys**.
2. Click the **Generate Your Key** button.
-To avoid hard coding configurations in your code, it is possible to specify configruation params
+To avoid hard coding configurations in your code, it is possible to specify configuration params
as the following environment variables (env variables will be used if parameters are not specified):
* DEMISTO_BASE_URL
* DEMISTO_API_KEY
* DEMISTO_USERNAME
* DEMISTO_PASSWORD
+* DEMISTO_HTTP_HEADERS (must be in the form of: header1=value1,header2=value2,header3=value3,...headerN=valueN)
* DEMISTO_VERIFY_SSL (true/false. Default: true)
* XSIAM_AUTH_ID (for Cortex XSIAM only. If set, Cortex XSIAM API will be used)
* SSL_CERT_FILE (specify an alternate certificate bundle)
@@ -718,7 +721,7 @@ Apache 2.0 - See [LICENSE](LICENSE) for more information.
%prep
-%autosetup -n demisto-py-3.2.8
+%autosetup -n demisto-py-3.2.9
%build
%py3_build
@@ -758,5 +761,5 @@ mv %{buildroot}/doclist.lst .
%{_docdir}/*
%changelog
-* Tue Apr 11 2023 Python_Bot <Python_Bot@openeuler.org> - 3.2.8-1
+* Sun Apr 23 2023 Python_Bot <Python_Bot@openeuler.org> - 3.2.9-1
- Package Spec generated