summaryrefslogtreecommitdiff
path: root/python-dev-up.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-dev-up.spec')
-rw-r--r--python-dev-up.spec166
1 files changed, 166 insertions, 0 deletions
diff --git a/python-dev-up.spec b/python-dev-up.spec
new file mode 100644
index 0000000..6ea38a1
--- /dev/null
+++ b/python-dev-up.spec
@@ -0,0 +1,166 @@
+%global _empty_manifest_terminate_build 0
+Name: python-dev-up
+Version: 2.0.0
+Release: 1
+Summary: Библиотека для работы с сервисом DEV-UP.
+License: MIT
+URL: https://github.com/lordralinc/dev_up
+Source0: https://mirrors.aliyun.com/pypi/web/packages/ba/6e/e2221fd4a6dfe0a8aa276fc96acc1f05159b90513112a1bebf295e1f9033/dev_up-2.0.0.tar.gz
+BuildArch: noarch
+
+Requires: python3-loguru
+Requires: python3-aiohttp
+Requires: python3-pydantic
+Requires: python3-Pygments
+Requires: python3-update
+Requires: python3-requests
+Requires: python3-cachetools
+
+%description
+# DEV UP API wrapper
+
+![PyPI](https://img.shields.io/pypi/v/dev-up)
+![PyPI - Python Version](https://img.shields.io/pypi/pyversions/dev-up)
+![GitHub](https://img.shields.io/github/license/lordralinc/dev_up)
+[![Downloads](https://pepy.tech/badge/dev-up)](https://pepy.tech/project/dev-up)
+## Установка
+```shell
+pip install dev_up
+```
+
+
+
+## Получение токена
+[dev-up.ru](https://dev-up.ru/lk)
+
+## Использование
+
+```python
+from dev_up import DevUpAPI
+
+api = DevUpAPI("token")
+profile = await api.profile.get()
+stickers = await api.vk.get_stickers(1)
+
+custom = await api.make_request(
+ "section.method",
+ data=dict(param1="foo", param2="bar")
+)
+```
+
+%package -n python3-dev-up
+Summary: Библиотека для работы с сервисом DEV-UP.
+Provides: python-dev-up
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-dev-up
+# DEV UP API wrapper
+
+![PyPI](https://img.shields.io/pypi/v/dev-up)
+![PyPI - Python Version](https://img.shields.io/pypi/pyversions/dev-up)
+![GitHub](https://img.shields.io/github/license/lordralinc/dev_up)
+[![Downloads](https://pepy.tech/badge/dev-up)](https://pepy.tech/project/dev-up)
+## Установка
+```shell
+pip install dev_up
+```
+
+
+
+## Получение токена
+[dev-up.ru](https://dev-up.ru/lk)
+
+## Использование
+
+```python
+from dev_up import DevUpAPI
+
+api = DevUpAPI("token")
+profile = await api.profile.get()
+stickers = await api.vk.get_stickers(1)
+
+custom = await api.make_request(
+ "section.method",
+ data=dict(param1="foo", param2="bar")
+)
+```
+
+%package help
+Summary: Development documents and examples for dev-up
+Provides: python3-dev-up-doc
+%description help
+# DEV UP API wrapper
+
+![PyPI](https://img.shields.io/pypi/v/dev-up)
+![PyPI - Python Version](https://img.shields.io/pypi/pyversions/dev-up)
+![GitHub](https://img.shields.io/github/license/lordralinc/dev_up)
+[![Downloads](https://pepy.tech/badge/dev-up)](https://pepy.tech/project/dev-up)
+## Установка
+```shell
+pip install dev_up
+```
+
+
+
+## Получение токена
+[dev-up.ru](https://dev-up.ru/lk)
+
+## Использование
+
+```python
+from dev_up import DevUpAPI
+
+api = DevUpAPI("token")
+profile = await api.profile.get()
+stickers = await api.vk.get_stickers(1)
+
+custom = await api.make_request(
+ "section.method",
+ data=dict(param1="foo", param2="bar")
+)
+```
+
+%prep
+%autosetup -n dev_up-2.0.0
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-dev-up -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Tue Jun 20 2023 Python_Bot <Python_Bot@openeuler.org> - 2.0.0-1
+- Package Spec generated