summaryrefslogtreecommitdiff
path: root/python-devinstaller-core.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-devinstaller-core.spec')
-rw-r--r--python-devinstaller-core.spec86
1 files changed, 86 insertions, 0 deletions
diff --git a/python-devinstaller-core.spec b/python-devinstaller-core.spec
new file mode 100644
index 0000000..7d97645
--- /dev/null
+++ b/python-devinstaller-core.spec
@@ -0,0 +1,86 @@
+%global _empty_manifest_terminate_build 0
+Name: python-devinstaller-core
+Version: 0.9.1
+Release: 1
+Summary: The core library for creating a Devinstaller application.
+License: MIT
+URL: https://justine.kizhak.com/projects/devinstaller-core-py
+Source0: https://mirrors.aliyun.com/pypi/web/packages/72/98/7bd7467f7a5965340dca481754f5ba923a142680288ffdf528bc953fc46c/devinstaller_core-0.9.1.tar.gz
+BuildArch: noarch
+
+Requires: python3-anymarkup
+Requires: python3-cerberus
+Requires: python3-pydantic
+Requires: python3-questionary
+Requires: python3-requests
+Requires: python3-rich
+Requires: python3-typeguard
+Requires: python3-oschmod
+
+%description
+[![forthebadge](https://forthebadge.com/images/badges/uses-git.svg)](https://forthebadge.com)
+[![forthebadge](https://forthebadge.com/images/badges/approved-by-george-costanza.svg)](https://forthebadge.com)
+[![forthebadge](https://forthebadge.com/images/badges/certified-snoop-lion.svg)](https://forthebadge.com)
+
+%package -n python3-devinstaller-core
+Summary: The core library for creating a Devinstaller application.
+Provides: python-devinstaller-core
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-devinstaller-core
+[![forthebadge](https://forthebadge.com/images/badges/uses-git.svg)](https://forthebadge.com)
+[![forthebadge](https://forthebadge.com/images/badges/approved-by-george-costanza.svg)](https://forthebadge.com)
+[![forthebadge](https://forthebadge.com/images/badges/certified-snoop-lion.svg)](https://forthebadge.com)
+
+%package help
+Summary: Development documents and examples for devinstaller-core
+Provides: python3-devinstaller-core-doc
+%description help
+[![forthebadge](https://forthebadge.com/images/badges/uses-git.svg)](https://forthebadge.com)
+[![forthebadge](https://forthebadge.com/images/badges/approved-by-george-costanza.svg)](https://forthebadge.com)
+[![forthebadge](https://forthebadge.com/images/badges/certified-snoop-lion.svg)](https://forthebadge.com)
+
+%prep
+%autosetup -n devinstaller_core-0.9.1
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-devinstaller-core -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Tue Jun 20 2023 Python_Bot <Python_Bot@openeuler.org> - 0.9.1-1
+- Package Spec generated