summaryrefslogtreecommitdiff
path: root/python-diamond-miner.spec
diff options
context:
space:
mode:
authorCoprDistGit <infra@openeuler.org>2023-04-11 10:54:27 +0000
committerCoprDistGit <infra@openeuler.org>2023-04-11 10:54:27 +0000
commita0f6a99a521e897ce908e8c438ea13e1a9e4e673 (patch)
treeb2e83b89bdeea9b8e844f6b710d67925488f1e9e /python-diamond-miner.spec
parentf21c081cbd8bca32f118b5f0603bf158c820462f (diff)
automatic import of python-diamond-miner
Diffstat (limited to 'python-diamond-miner.spec')
-rw-r--r--python-diamond-miner.spec87
1 files changed, 87 insertions, 0 deletions
diff --git a/python-diamond-miner.spec b/python-diamond-miner.spec
new file mode 100644
index 0000000..a4f76e7
--- /dev/null
+++ b/python-diamond-miner.spec
@@ -0,0 +1,87 @@
+%global _empty_manifest_terminate_build 0
+Name: python-diamond-miner
+Version: 1.0.3
+Release: 1
+Summary: High-speed, Internet-scale, load-balanced paths discovery.
+License: MIT
+URL: https://github.com/dioptra-io/diamond-miner
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/15/fc/34b594855f28d6710bda1f9ba87b646b3530cc427df1b1bf95e7679d0e14/diamond_miner-1.0.3.tar.gz
+BuildArch: noarch
+
+Requires: python3-pych-client
+Requires: python3-pygfc
+Requires: python3-zstandard
+
+%description
+[pych-client](https://github.com/dioptra-io/pych-client) | [MIT](https://opensource.org/licenses/MIT) | Querying the database
+[pygfc](https://github.com/maxmouchet/gfc) | [MIT](https://opensource.org/licenses/MIT) | Generating random permutations
+[python-zstandard](https://github.com/indygreg/python-zstandard) | [3-clause BSD](https://opensource.org/licenses/BSD-3-Clause) | Compression
+[^1]: As of v0.1.0, diamond-miner can discover the multipath topology in less than a day when probing at 100k pps.
+[^2]: Vermeulen, Kevin, et al. ["Diamond-Miner: Comprehensive Discovery of the Internet's Topology Diamonds."](https://www.usenix.org/system/files/nsdi20-paper-vermeulen.pdf) _17th USENIX Symposium on Networked Systems Design and Implementation (NSDI 20)_. 2020.
+
+%package -n python3-diamond-miner
+Summary: High-speed, Internet-scale, load-balanced paths discovery.
+Provides: python-diamond-miner
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-diamond-miner
+[pych-client](https://github.com/dioptra-io/pych-client) | [MIT](https://opensource.org/licenses/MIT) | Querying the database
+[pygfc](https://github.com/maxmouchet/gfc) | [MIT](https://opensource.org/licenses/MIT) | Generating random permutations
+[python-zstandard](https://github.com/indygreg/python-zstandard) | [3-clause BSD](https://opensource.org/licenses/BSD-3-Clause) | Compression
+[^1]: As of v0.1.0, diamond-miner can discover the multipath topology in less than a day when probing at 100k pps.
+[^2]: Vermeulen, Kevin, et al. ["Diamond-Miner: Comprehensive Discovery of the Internet's Topology Diamonds."](https://www.usenix.org/system/files/nsdi20-paper-vermeulen.pdf) _17th USENIX Symposium on Networked Systems Design and Implementation (NSDI 20)_. 2020.
+
+%package help
+Summary: Development documents and examples for diamond-miner
+Provides: python3-diamond-miner-doc
+%description help
+[pych-client](https://github.com/dioptra-io/pych-client) | [MIT](https://opensource.org/licenses/MIT) | Querying the database
+[pygfc](https://github.com/maxmouchet/gfc) | [MIT](https://opensource.org/licenses/MIT) | Generating random permutations
+[python-zstandard](https://github.com/indygreg/python-zstandard) | [3-clause BSD](https://opensource.org/licenses/BSD-3-Clause) | Compression
+[^1]: As of v0.1.0, diamond-miner can discover the multipath topology in less than a day when probing at 100k pps.
+[^2]: Vermeulen, Kevin, et al. ["Diamond-Miner: Comprehensive Discovery of the Internet's Topology Diamonds."](https://www.usenix.org/system/files/nsdi20-paper-vermeulen.pdf) _17th USENIX Symposium on Networked Systems Design and Implementation (NSDI 20)_. 2020.
+
+%prep
+%autosetup -n diamond-miner-1.0.3
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-diamond-miner -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Tue Apr 11 2023 Python_Bot <Python_Bot@openeuler.org> - 1.0.3-1
+- Package Spec generated