summaryrefslogtreecommitdiff
path: root/python-dictor.spec
diff options
context:
space:
mode:
authorCoprDistGit <infra@openeuler.org>2023-04-10 21:07:09 +0000
committerCoprDistGit <infra@openeuler.org>2023-04-10 21:07:09 +0000
commit4ea5314eb02a280f481f331d19eba7db6927f21f (patch)
tree977ec646f84b4001a6ef27d2ac3206b3dfbd6032 /python-dictor.spec
parentd5d5abe5a4e45921ed4e132aa378d84e7a50cfb2 (diff)
automatic import of python-dictor
Diffstat (limited to 'python-dictor.spec')
-rw-r--r--python-dictor.spec180
1 files changed, 180 insertions, 0 deletions
diff --git a/python-dictor.spec b/python-dictor.spec
new file mode 100644
index 0000000..3a45bbe
--- /dev/null
+++ b/python-dictor.spec
@@ -0,0 +1,180 @@
+%global _empty_manifest_terminate_build 0
+Name: python-dictor
+Version: 0.1.11
+Release: 1
+Summary: an elegant dictionary and JSON handler
+License: MIT
+URL: https://github.com/perfecto25/dictor
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/cd/ce/1d2796e4afc518cbe6e263f0a4ab51f961387f3ca27902714d09baeb4d75/dictor-0.1.11.tar.gz
+BuildArch: noarch
+
+
+%description
+## Installation
+ pip install dictor
+## Usage
+sample.json
+```json
+{
+ "characters": {
+ "Lonestar": {
+ "id": 55923,
+ "role": "renegade",
+ "items": ["space winnebago", "leather jacket"]
+ },
+ "Barfolomew": {
+ "id": 55924,
+ "role": "mawg",
+ "items": ["peanut butter jar", "waggy tail"]
+ },
+ "Dark Helmet": {
+ "id": 99999,
+ "role": "Good is dumb",
+ "items": ["Shwartz", "helmet"]
+ },
+ "Skroob": {
+ "id": 12345,
+ "role": "Spaceballs CEO",
+ "items": ["luggage"]
+ }
+ }
+}
+```
+now lets get info on all Characters
+```python
+from dictor import dictor
+with open('sample.json') as data:
+ data = json.load(data)
+print(dictor(data, 'characters'))
+{u'Lonestar': {u'items': [u'space winnebago', u'leather jacket'], u'role': u'renegade', u'id': 55923}, u'Dark Helmet': {u'items': [u'Shwartz', u'helmet'], u'role': u'Good is dumb', u'id': 99999}, u'Barfolomew': {u'items': [u'peanut butter jar', u'waggy tail'], u'role': u'mawg', u'id': 55924}, u'Skroob': {u'items': [u'luggage'], u'role': u'Spaceballs CEO', u'id': 12345}}
+
+%package -n python3-dictor
+Summary: an elegant dictionary and JSON handler
+Provides: python-dictor
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-dictor
+## Installation
+ pip install dictor
+## Usage
+sample.json
+```json
+{
+ "characters": {
+ "Lonestar": {
+ "id": 55923,
+ "role": "renegade",
+ "items": ["space winnebago", "leather jacket"]
+ },
+ "Barfolomew": {
+ "id": 55924,
+ "role": "mawg",
+ "items": ["peanut butter jar", "waggy tail"]
+ },
+ "Dark Helmet": {
+ "id": 99999,
+ "role": "Good is dumb",
+ "items": ["Shwartz", "helmet"]
+ },
+ "Skroob": {
+ "id": 12345,
+ "role": "Spaceballs CEO",
+ "items": ["luggage"]
+ }
+ }
+}
+```
+now lets get info on all Characters
+```python
+from dictor import dictor
+with open('sample.json') as data:
+ data = json.load(data)
+print(dictor(data, 'characters'))
+{u'Lonestar': {u'items': [u'space winnebago', u'leather jacket'], u'role': u'renegade', u'id': 55923}, u'Dark Helmet': {u'items': [u'Shwartz', u'helmet'], u'role': u'Good is dumb', u'id': 99999}, u'Barfolomew': {u'items': [u'peanut butter jar', u'waggy tail'], u'role': u'mawg', u'id': 55924}, u'Skroob': {u'items': [u'luggage'], u'role': u'Spaceballs CEO', u'id': 12345}}
+
+%package help
+Summary: Development documents and examples for dictor
+Provides: python3-dictor-doc
+%description help
+## Installation
+ pip install dictor
+## Usage
+sample.json
+```json
+{
+ "characters": {
+ "Lonestar": {
+ "id": 55923,
+ "role": "renegade",
+ "items": ["space winnebago", "leather jacket"]
+ },
+ "Barfolomew": {
+ "id": 55924,
+ "role": "mawg",
+ "items": ["peanut butter jar", "waggy tail"]
+ },
+ "Dark Helmet": {
+ "id": 99999,
+ "role": "Good is dumb",
+ "items": ["Shwartz", "helmet"]
+ },
+ "Skroob": {
+ "id": 12345,
+ "role": "Spaceballs CEO",
+ "items": ["luggage"]
+ }
+ }
+}
+```
+now lets get info on all Characters
+```python
+from dictor import dictor
+with open('sample.json') as data:
+ data = json.load(data)
+print(dictor(data, 'characters'))
+{u'Lonestar': {u'items': [u'space winnebago', u'leather jacket'], u'role': u'renegade', u'id': 55923}, u'Dark Helmet': {u'items': [u'Shwartz', u'helmet'], u'role': u'Good is dumb', u'id': 99999}, u'Barfolomew': {u'items': [u'peanut butter jar', u'waggy tail'], u'role': u'mawg', u'id': 55924}, u'Skroob': {u'items': [u'luggage'], u'role': u'Spaceballs CEO', u'id': 12345}}
+
+%prep
+%autosetup -n dictor-0.1.11
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-dictor -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Mon Apr 10 2023 Python_Bot <Python_Bot@openeuler.org> - 0.1.11-1
+- Package Spec generated