summaryrefslogtreecommitdiff
path: root/python-dirutility.spec
diff options
context:
space:
mode:
authorCoprDistGit <infra@openeuler.org>2023-05-18 06:29:27 +0000
committerCoprDistGit <infra@openeuler.org>2023-05-18 06:29:27 +0000
commit0de299472805c3575b685cbd2481af2fcfcb90fb (patch)
tree61f8613a02725d0ef1f931f2fa050ae36702e7ac /python-dirutility.spec
parent22c9977b639f1e70eff4b4d88c42c262f58d7a21 (diff)
automatic import of python-dirutility
Diffstat (limited to 'python-dirutility.spec')
-rw-r--r--python-dirutility.spec72
1 files changed, 72 insertions, 0 deletions
diff --git a/python-dirutility.spec b/python-dirutility.spec
new file mode 100644
index 0000000..7ecf2df
--- /dev/null
+++ b/python-dirutility.spec
@@ -0,0 +1,72 @@
+%global _empty_manifest_terminate_build 0
+Name: python-dirutility
+Version: 0.7.20
+Release: 1
+Summary: Add compare module and GUI to parse two directories and return lists of unique files.
+License: MIT License
+URL: https://github.com/sfneal/dirutility
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/fa/eb/e4b4ae2cb249bbd1eed8b1cc844f5889bb23f5d75d54ebab9327987ac58b/dirutility-0.7.20.tar.gz
+BuildArch: noarch
+
+
+%description
+Utility functions for quickly reading directory contents and refactoring folder structure
+
+%package -n python3-dirutility
+Summary: Add compare module and GUI to parse two directories and return lists of unique files.
+Provides: python-dirutility
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-dirutility
+Utility functions for quickly reading directory contents and refactoring folder structure
+
+%package help
+Summary: Development documents and examples for dirutility
+Provides: python3-dirutility-doc
+%description help
+Utility functions for quickly reading directory contents and refactoring folder structure
+
+%prep
+%autosetup -n dirutility-0.7.20
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-dirutility -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Thu May 18 2023 Python_Bot <Python_Bot@openeuler.org> - 0.7.20-1
+- Package Spec generated