summaryrefslogtreecommitdiff
path: root/python-discord-musicbot.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-discord-musicbot.spec')
-rw-r--r--python-discord-musicbot.spec84
1 files changed, 84 insertions, 0 deletions
diff --git a/python-discord-musicbot.spec b/python-discord-musicbot.spec
new file mode 100644
index 0000000..39d822c
--- /dev/null
+++ b/python-discord-musicbot.spec
@@ -0,0 +1,84 @@
+%global _empty_manifest_terminate_build 0
+Name: python-discord-musicbot
+Version: 0.0.3.dev20170604
+Release: 1
+Summary: MusicBot bot for Discord.
+License: https://opensource.org/licenses/BSD-3-Clause
+URL: https://github.com/andasilva/MusicBot
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/42/a4/e398795ab1aa297393c6839ce3d265c1dcb4e3f8482ae253ec9920dca3df/discord-musicbot-0.0.3.dev20170604.tar.gz
+BuildArch: noarch
+
+Requires: python3-aiohttp
+Requires: python3-selenium
+Requires: python3-spotipy
+Requires: python3-Sphinx
+Requires: python3-sphinxcontrib-trio
+Requires: python3-aiodns
+Requires: python3-cchardet
+Requires: python3-flake8
+Requires: python3-isort
+Requires: python3-pycodestyle
+Requires: python3-pydocstyle
+Requires: python3-rstcheck
+
+%description
+
+
+%package -n python3-discord-musicbot
+Summary: MusicBot bot for Discord.
+Provides: python-discord-musicbot
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-discord-musicbot
+
+
+%package help
+Summary: Development documents and examples for discord-musicbot
+Provides: python3-discord-musicbot-doc
+%description help
+
+
+%prep
+%autosetup -n discord-musicbot-0.0.3.dev20170604
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-discord-musicbot -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Tue Apr 11 2023 Python_Bot <Python_Bot@openeuler.org> - 0.0.3.dev20170604-1
+- Package Spec generated