summaryrefslogtreecommitdiff
path: root/python-dit.spec
diff options
context:
space:
mode:
authorCoprDistGit <infra@openeuler.org>2023-05-18 06:39:55 +0000
committerCoprDistGit <infra@openeuler.org>2023-05-18 06:39:55 +0000
commit1ea5aba21db9e99a1cae21bbcd38c8b0402d7e11 (patch)
tree2fb4a41cd430118825e719ab54ef90139734ea95 /python-dit.spec
parentdbc3944e1fab5290b3e63567f1756a2cf33c49c2 (diff)
automatic import of python-dit
Diffstat (limited to 'python-dit.spec')
-rw-r--r--python-dit.spec116
1 files changed, 116 insertions, 0 deletions
diff --git a/python-dit.spec b/python-dit.spec
new file mode 100644
index 0000000..a923e6d
--- /dev/null
+++ b/python-dit.spec
@@ -0,0 +1,116 @@
+%global _empty_manifest_terminate_build 0
+Name: python-dit
+Version: 1.5
+Release: 1
+Summary: Python package for information theory.
+License: BSD
+URL: http://dit.io
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/9a/44/4c9ca52132947daafccf1f52f5b0cebc7f1bb62e34ae7723943682b5e686/dit-1.5.tar.gz
+BuildArch: noarch
+
+Requires: python3-boltons
+Requires: python3-debtcollector
+Requires: python3-lattices
+Requires: python3-networkx
+Requires: python3-numpy
+Requires: python3-PLTable
+Requires: python3-scipy
+Requires: python3-pypoman
+
+%description
+Information theory is a powerful extension to probability and statistics, quantifying dependencies
+among arbitrary random variables in a way that is consistent and comparable across systems and
+scales. Information theory was originally developed to quantify how quickly and reliably information
+could be transmitted across an arbitrary channel. The demands of modern, data-driven science have
+been coopting and extending these quantities and methods into unknown, multivariate settings where
+the interpretation and best practices are not known. For example, there are at least four reasonable
+multivariate generalizations of the mutual information, none of which inherit all the
+interpretations of the standard bivariate case. Which is best to use is context-dependent. ``dit``
+implements a vast range of multivariate information measures in an effort to allow information
+practitioners to study how these various measures behave and interact in a variety of contexts. We
+hope that having all these measures and techniques implemented in one place will allow the
+development of robust techniques for the automated quantification of dependencies within a system
+and concrete interpretation of what those dependencies mean.
+
+%package -n python3-dit
+Summary: Python package for information theory.
+Provides: python-dit
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-dit
+Information theory is a powerful extension to probability and statistics, quantifying dependencies
+among arbitrary random variables in a way that is consistent and comparable across systems and
+scales. Information theory was originally developed to quantify how quickly and reliably information
+could be transmitted across an arbitrary channel. The demands of modern, data-driven science have
+been coopting and extending these quantities and methods into unknown, multivariate settings where
+the interpretation and best practices are not known. For example, there are at least four reasonable
+multivariate generalizations of the mutual information, none of which inherit all the
+interpretations of the standard bivariate case. Which is best to use is context-dependent. ``dit``
+implements a vast range of multivariate information measures in an effort to allow information
+practitioners to study how these various measures behave and interact in a variety of contexts. We
+hope that having all these measures and techniques implemented in one place will allow the
+development of robust techniques for the automated quantification of dependencies within a system
+and concrete interpretation of what those dependencies mean.
+
+%package help
+Summary: Development documents and examples for dit
+Provides: python3-dit-doc
+%description help
+Information theory is a powerful extension to probability and statistics, quantifying dependencies
+among arbitrary random variables in a way that is consistent and comparable across systems and
+scales. Information theory was originally developed to quantify how quickly and reliably information
+could be transmitted across an arbitrary channel. The demands of modern, data-driven science have
+been coopting and extending these quantities and methods into unknown, multivariate settings where
+the interpretation and best practices are not known. For example, there are at least four reasonable
+multivariate generalizations of the mutual information, none of which inherit all the
+interpretations of the standard bivariate case. Which is best to use is context-dependent. ``dit``
+implements a vast range of multivariate information measures in an effort to allow information
+practitioners to study how these various measures behave and interact in a variety of contexts. We
+hope that having all these measures and techniques implemented in one place will allow the
+development of robust techniques for the automated quantification of dependencies within a system
+and concrete interpretation of what those dependencies mean.
+
+%prep
+%autosetup -n dit-1.5
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-dit -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Thu May 18 2023 Python_Bot <Python_Bot@openeuler.org> - 1.5-1
+- Package Spec generated