summaryrefslogtreecommitdiff
path: root/python-dj-input-flow.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-dj-input-flow.spec')
-rw-r--r--python-dj-input-flow.spec72
1 files changed, 72 insertions, 0 deletions
diff --git a/python-dj-input-flow.spec b/python-dj-input-flow.spec
new file mode 100644
index 0000000..701bde7
--- /dev/null
+++ b/python-dj-input-flow.spec
@@ -0,0 +1,72 @@
+%global _empty_manifest_terminate_build 0
+Name: python-dj-input-flow
+Version: 0.1.9
+Release: 1
+Summary: Django app to handle data flow
+License: MIT
+URL: https://github.com/kverdecia/dj-input-flow
+Source0: https://mirrors.aliyun.com/pypi/web/packages/40/64/a32de77d1a40c398dc203185c59343df3713140203f622d507618789ea81/dj-input-flow-0.1.9.tar.gz
+BuildArch: noarch
+
+
+%description
+
+
+%package -n python3-dj-input-flow
+Summary: Django app to handle data flow
+Provides: python-dj-input-flow
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-dj-input-flow
+
+
+%package help
+Summary: Development documents and examples for dj-input-flow
+Provides: python3-dj-input-flow-doc
+%description help
+
+
+%prep
+%autosetup -n dj-input-flow-0.1.9
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-dj-input-flow -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Tue Jun 20 2023 Python_Bot <Python_Bot@openeuler.org> - 0.1.9-1
+- Package Spec generated