summaryrefslogtreecommitdiff
path: root/python-django-chartjs.spec
diff options
context:
space:
mode:
authorCoprDistGit <infra@openeuler.org>2023-04-12 02:26:19 +0000
committerCoprDistGit <infra@openeuler.org>2023-04-12 02:26:19 +0000
commit896ffe7b4605db853b21d2ecdfe18fbd616ce5e8 (patch)
tree533655f4c688408cc4c98ad37aba13e7d238ea46 /python-django-chartjs.spec
parent34e229453427dd911e8555247158fcd86bc312f1 (diff)
automatic import of python-django-chartjs
Diffstat (limited to 'python-django-chartjs.spec')
-rw-r--r--python-django-chartjs.spec90
1 files changed, 90 insertions, 0 deletions
diff --git a/python-django-chartjs.spec b/python-django-chartjs.spec
new file mode 100644
index 0000000..08f1f97
--- /dev/null
+++ b/python-django-chartjs.spec
@@ -0,0 +1,90 @@
+%global _empty_manifest_terminate_build 0
+Name: python-django-chartjs
+Version: 2.3.0
+Release: 1
+Summary: Django Chart.js and Hightchart ajax views
+License: BSD Licence
+URL: https://github.com/peopledoc/django-chartjs
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/b8/93/875137021a36005b777f9c7b6468dac5b20bf5aea62e4417ffe19d5875dd/django-chartjs-2.3.0.tar.gz
+BuildArch: noarch
+
+
+%description
+Install django-chartjs::
+ pip install django-chartjs
+Add it to your ``INSTALLED_APPS`` settings::
+ INSTALLED_APPS = (
+ '...',
+ 'chartjs',
+ )
+
+%package -n python3-django-chartjs
+Summary: Django Chart.js and Hightchart ajax views
+Provides: python-django-chartjs
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-django-chartjs
+Install django-chartjs::
+ pip install django-chartjs
+Add it to your ``INSTALLED_APPS`` settings::
+ INSTALLED_APPS = (
+ '...',
+ 'chartjs',
+ )
+
+%package help
+Summary: Development documents and examples for django-chartjs
+Provides: python3-django-chartjs-doc
+%description help
+Install django-chartjs::
+ pip install django-chartjs
+Add it to your ``INSTALLED_APPS`` settings::
+ INSTALLED_APPS = (
+ '...',
+ 'chartjs',
+ )
+
+%prep
+%autosetup -n django-chartjs-2.3.0
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-django-chartjs -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Wed Apr 12 2023 Python_Bot <Python_Bot@openeuler.org> - 2.3.0-1
+- Package Spec generated