summaryrefslogtreecommitdiff
path: root/python-django-constance.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-django-constance.spec')
-rw-r--r--python-django-constance.spec92
1 files changed, 92 insertions, 0 deletions
diff --git a/python-django-constance.spec b/python-django-constance.spec
new file mode 100644
index 0000000..57bdd18
--- /dev/null
+++ b/python-django-constance.spec
@@ -0,0 +1,92 @@
+%global _empty_manifest_terminate_build 0
+Name: python-django-constance
+Version: 2.9.1
+Release: 1
+Summary: Django live settings with pluggable backends, including Redis.
+License: BSD
+URL: https://github.com/jazzband/django-constance
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/3d/d1/07c31ee700fa1ccaa45bf4416562e4ae8b22a96d9db0968d918eecbc25be/django-constance-2.9.1.tar.gz
+BuildArch: noarch
+
+Requires: python3-django-picklefield
+Requires: python3-redis
+
+%description
+A Django app for storing dynamic settings in pluggable backends (Redis and
+Django model backend built in) with an integration with the Django admin app.
+For more information see the documentation at:
+https://django-constance.readthedocs.io/
+If you have questions or have trouble using the app please file a bug report
+at:
+https://github.com/jazzband/django-constance/issues
+
+%package -n python3-django-constance
+Summary: Django live settings with pluggable backends, including Redis.
+Provides: python-django-constance
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-django-constance
+A Django app for storing dynamic settings in pluggable backends (Redis and
+Django model backend built in) with an integration with the Django admin app.
+For more information see the documentation at:
+https://django-constance.readthedocs.io/
+If you have questions or have trouble using the app please file a bug report
+at:
+https://github.com/jazzband/django-constance/issues
+
+%package help
+Summary: Development documents and examples for django-constance
+Provides: python3-django-constance-doc
+%description help
+A Django app for storing dynamic settings in pluggable backends (Redis and
+Django model backend built in) with an integration with the Django admin app.
+For more information see the documentation at:
+https://django-constance.readthedocs.io/
+If you have questions or have trouble using the app please file a bug report
+at:
+https://github.com/jazzband/django-constance/issues
+
+%prep
+%autosetup -n django-constance-2.9.1
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-django-constance -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Mon Apr 10 2023 Python_Bot <Python_Bot@openeuler.org> - 2.9.1-1
+- Package Spec generated