summaryrefslogtreecommitdiff
path: root/python-django-embed-template.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-django-embed-template.spec')
-rw-r--r--python-django-embed-template.spec73
1 files changed, 73 insertions, 0 deletions
diff --git a/python-django-embed-template.spec b/python-django-embed-template.spec
new file mode 100644
index 0000000..fb74265
--- /dev/null
+++ b/python-django-embed-template.spec
@@ -0,0 +1,73 @@
+%global _empty_manifest_terminate_build 0
+Name: python-django-embed-template
+Version: 0.2.0
+Release: 1
+Summary: Override blocks in included templates
+License: CC0
+URL: https://github.com/joostrijneveld/django-embed-template
+Source0: https://mirrors.aliyun.com/pypi/web/packages/68/67/cb8f3b472953d10e6f4c2b6b8d995341b6f4081ed2710dce248fe6b39ab7/django-embed-template-0.2.0.tar.gz
+BuildArch: noarch
+
+Requires: python3-django
+
+%description
+This package adds the ``{% embed %}`` templatetag. This tag combines the functionality of `the include tag <https://docs.djangoproject.com/en/1.10/ref/templates/builtins/#include>`__ and `the extends tag <https://docs.djangoproject.com/en/1.10/ref/templates/builtins/#extends>`__ to allow for more flexible and extensible modular template usage. Inspired by `twig's embed tag <http://twig.sensiolabs.org/doc/tags/embed.html>`__, this tag lets you override blocks that were defined in the included template.
+
+%package -n python3-django-embed-template
+Summary: Override blocks in included templates
+Provides: python-django-embed-template
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-django-embed-template
+This package adds the ``{% embed %}`` templatetag. This tag combines the functionality of `the include tag <https://docs.djangoproject.com/en/1.10/ref/templates/builtins/#include>`__ and `the extends tag <https://docs.djangoproject.com/en/1.10/ref/templates/builtins/#extends>`__ to allow for more flexible and extensible modular template usage. Inspired by `twig's embed tag <http://twig.sensiolabs.org/doc/tags/embed.html>`__, this tag lets you override blocks that were defined in the included template.
+
+%package help
+Summary: Development documents and examples for django-embed-template
+Provides: python3-django-embed-template-doc
+%description help
+This package adds the ``{% embed %}`` templatetag. This tag combines the functionality of `the include tag <https://docs.djangoproject.com/en/1.10/ref/templates/builtins/#include>`__ and `the extends tag <https://docs.djangoproject.com/en/1.10/ref/templates/builtins/#extends>`__ to allow for more flexible and extensible modular template usage. Inspired by `twig's embed tag <http://twig.sensiolabs.org/doc/tags/embed.html>`__, this tag lets you override blocks that were defined in the included template.
+
+%prep
+%autosetup -n django-embed-template-0.2.0
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-django-embed-template -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Tue Jun 20 2023 Python_Bot <Python_Bot@openeuler.org> - 0.2.0-1
+- Package Spec generated