summaryrefslogtreecommitdiff
path: root/python-django-fluent-dashboard.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-django-fluent-dashboard.spec')
-rw-r--r--python-django-fluent-dashboard.spec106
1 files changed, 106 insertions, 0 deletions
diff --git a/python-django-fluent-dashboard.spec b/python-django-fluent-dashboard.spec
new file mode 100644
index 0000000..b791cf5
--- /dev/null
+++ b/python-django-fluent-dashboard.spec
@@ -0,0 +1,106 @@
+%global _empty_manifest_terminate_build 0
+Name: python-django-fluent-dashboard
+Version: 2.0
+Release: 1
+Summary: An improved django-admin-tools dashboard for Django projects
+License: Apache 2.0
+URL: https://github.com/edoburu/django-fluent-dashboard
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/33/da/83b0f150bc0864902c24d9dbf88a94012456ae0b3ad169de1513874f7704/django-fluent-dashboard-2.0.tar.gz
+BuildArch: noarch
+
+Requires: python3-django-admin-tools
+Requires: python3-dashboardmods
+Requires: python3-feedparser
+Requires: python3-varnish
+
+%description
+The ``fluent_dashboard`` module offers a custom admin dashboard, built on top of
+django-admin-tools_ (`docs <https://django-admin-tools.readthedocs.io/>`_).
+The django-admin-tools_ package provides a default mechanism to replace the standard Django
+admin homepage with a widget based dashboard. The ``fluent_dashboard`` module extends this,
+by providing additional widgets (called "modules") such as:
+* a "icon list" module for the admin homepage.
+* a "welcome" module for the admin homepage.
+* a configurable module layout for the admin homepage, through ``settings.py``.
+* a "return to site" link.
+* an optional "cache statistics" module.
+Documentation can be found at: https://django-fluent-dashboard.readthedocs.io/
+
+%package -n python3-django-fluent-dashboard
+Summary: An improved django-admin-tools dashboard for Django projects
+Provides: python-django-fluent-dashboard
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-django-fluent-dashboard
+The ``fluent_dashboard`` module offers a custom admin dashboard, built on top of
+django-admin-tools_ (`docs <https://django-admin-tools.readthedocs.io/>`_).
+The django-admin-tools_ package provides a default mechanism to replace the standard Django
+admin homepage with a widget based dashboard. The ``fluent_dashboard`` module extends this,
+by providing additional widgets (called "modules") such as:
+* a "icon list" module for the admin homepage.
+* a "welcome" module for the admin homepage.
+* a configurable module layout for the admin homepage, through ``settings.py``.
+* a "return to site" link.
+* an optional "cache statistics" module.
+Documentation can be found at: https://django-fluent-dashboard.readthedocs.io/
+
+%package help
+Summary: Development documents and examples for django-fluent-dashboard
+Provides: python3-django-fluent-dashboard-doc
+%description help
+The ``fluent_dashboard`` module offers a custom admin dashboard, built on top of
+django-admin-tools_ (`docs <https://django-admin-tools.readthedocs.io/>`_).
+The django-admin-tools_ package provides a default mechanism to replace the standard Django
+admin homepage with a widget based dashboard. The ``fluent_dashboard`` module extends this,
+by providing additional widgets (called "modules") such as:
+* a "icon list" module for the admin homepage.
+* a "welcome" module for the admin homepage.
+* a configurable module layout for the admin homepage, through ``settings.py``.
+* a "return to site" link.
+* an optional "cache statistics" module.
+Documentation can be found at: https://django-fluent-dashboard.readthedocs.io/
+
+%prep
+%autosetup -n django-fluent-dashboard-2.0
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-django-fluent-dashboard -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Wed May 31 2023 Python_Bot <Python_Bot@openeuler.org> - 2.0-1
+- Package Spec generated