summaryrefslogtreecommitdiff
path: root/python-django-naomi.spec
diff options
context:
space:
mode:
authorCoprDistGit <infra@openeuler.org>2023-05-10 06:08:50 +0000
committerCoprDistGit <infra@openeuler.org>2023-05-10 06:08:50 +0000
commit31c66bb173ae6e151469ff3241e90d889d86f8f5 (patch)
treeeae4fd350e955c7de29b51b57a3393864dcc4b3a /python-django-naomi.spec
parent044561454880d89090b4575ac933d6da65c663b2 (diff)
automatic import of python-django-naomi
Diffstat (limited to 'python-django-naomi.spec')
-rw-r--r--python-django-naomi.spec72
1 files changed, 72 insertions, 0 deletions
diff --git a/python-django-naomi.spec b/python-django-naomi.spec
new file mode 100644
index 0000000..9870bd1
--- /dev/null
+++ b/python-django-naomi.spec
@@ -0,0 +1,72 @@
+%global _empty_manifest_terminate_build 0
+Name: python-django-naomi
+Version: 0.8
+Release: 1
+Summary: Email backend for Django. Preview your email in browser instead of sending it.
+License: MIT
+URL: https://github.com/edwinlunando/django-naomi
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/d1/a4/4e824a6171687aea4c8d71515a907521b32bee50401ee20dddfd5b362175/django-naomi-0.8.tar.gz
+BuildArch: noarch
+
+
+%description
+Django-naomi is a email backend for Django that let you preview email from your web browser instead of sending it using SMTP server. This is perfect for development environment that lack of SMTP server or you want to debug the email message. Attachment will be shown as link. This library is inspired from `Letter Opener <https://github.com/ryanb/letter_opener>`_.
+
+%package -n python3-django-naomi
+Summary: Email backend for Django. Preview your email in browser instead of sending it.
+Provides: python-django-naomi
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-django-naomi
+Django-naomi is a email backend for Django that let you preview email from your web browser instead of sending it using SMTP server. This is perfect for development environment that lack of SMTP server or you want to debug the email message. Attachment will be shown as link. This library is inspired from `Letter Opener <https://github.com/ryanb/letter_opener>`_.
+
+%package help
+Summary: Development documents and examples for django-naomi
+Provides: python3-django-naomi-doc
+%description help
+Django-naomi is a email backend for Django that let you preview email from your web browser instead of sending it using SMTP server. This is perfect for development environment that lack of SMTP server or you want to debug the email message. Attachment will be shown as link. This library is inspired from `Letter Opener <https://github.com/ryanb/letter_opener>`_.
+
+%prep
+%autosetup -n django-naomi-0.8
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-django-naomi -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Wed May 10 2023 Python_Bot <Python_Bot@openeuler.org> - 0.8-1
+- Package Spec generated