summaryrefslogtreecommitdiff
path: root/python-django-query-profiler.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-django-query-profiler.spec')
-rw-r--r--python-django-query-profiler.spec79
1 files changed, 79 insertions, 0 deletions
diff --git a/python-django-query-profiler.spec b/python-django-query-profiler.spec
new file mode 100644
index 0000000..0d7a46e
--- /dev/null
+++ b/python-django-query-profiler.spec
@@ -0,0 +1,79 @@
+%global _empty_manifest_terminate_build 0
+Name: python-django-query-profiler
+Version: 0.9
+Release: 1
+Summary: Django query profiler
+License: BSD-3-Clause
+URL: https://github.com/django-query-profiler/django-query-profiler
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/79/99/05c50f82ec5ae4bf04fb5b763873295203d957bf7f0d7d4e2bb861a6e1dd/django-query-profiler-0.9.tar.gz
+BuildArch: noarch
+
+Requires: python3-setuptools
+Requires: python3-django
+Requires: python3-mo-sql-parsing
+Requires: python3-redis
+Requires: python3-mmh3
+Requires: python3-isort
+Requires: python3-dataclasses
+
+%description
+
+
+%package -n python3-django-query-profiler
+Summary: Django query profiler
+Provides: python-django-query-profiler
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-django-query-profiler
+
+
+%package help
+Summary: Development documents and examples for django-query-profiler
+Provides: python3-django-query-profiler-doc
+%description help
+
+
+%prep
+%autosetup -n django-query-profiler-0.9
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-django-query-profiler -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Mon May 15 2023 Python_Bot <Python_Bot@openeuler.org> - 0.9-1
+- Package Spec generated