summaryrefslogtreecommitdiff
path: root/python-django-requestlogging-redux.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-django-requestlogging-redux.spec')
-rw-r--r--python-django-requestlogging-redux.spec75
1 files changed, 75 insertions, 0 deletions
diff --git a/python-django-requestlogging-redux.spec b/python-django-requestlogging-redux.spec
new file mode 100644
index 0000000..5bf9968
--- /dev/null
+++ b/python-django-requestlogging-redux.spec
@@ -0,0 +1,75 @@
+%global _empty_manifest_terminate_build 0
+Name: python-django-requestlogging-redux
+Version: 1.2.1
+Release: 1
+Summary: Adds information about requests to logging records.
+License: BSD License
+URL: https://github.com/tarkatronic/django-requestlogging
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/af/d3/c52922bf8a9abc0e7c848bab899f46cbb982ab7d68d910b6aa8547c6bd07/django-requestlogging-redux-1.2.1.tar.gz
+BuildArch: noarch
+
+
+%description
+This package provides a logging filter and middleware to add
+information about the current request to the logging record.
+
+%package -n python3-django-requestlogging-redux
+Summary: Adds information about requests to logging records.
+Provides: python-django-requestlogging-redux
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-django-requestlogging-redux
+This package provides a logging filter and middleware to add
+information about the current request to the logging record.
+
+%package help
+Summary: Development documents and examples for django-requestlogging-redux
+Provides: python3-django-requestlogging-redux-doc
+%description help
+This package provides a logging filter and middleware to add
+information about the current request to the logging record.
+
+%prep
+%autosetup -n django-requestlogging-redux-1.2.1
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-django-requestlogging-redux -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Wed Apr 12 2023 Python_Bot <Python_Bot@openeuler.org> - 1.2.1-1
+- Package Spec generated