summaryrefslogtreecommitdiff
path: root/python-djangorestframework-link-header-pagination.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-djangorestframework-link-header-pagination.spec')
-rw-r--r--python-djangorestframework-link-header-pagination.spec72
1 files changed, 72 insertions, 0 deletions
diff --git a/python-djangorestframework-link-header-pagination.spec b/python-djangorestframework-link-header-pagination.spec
new file mode 100644
index 0000000..3c9eca0
--- /dev/null
+++ b/python-djangorestframework-link-header-pagination.spec
@@ -0,0 +1,72 @@
+%global _empty_manifest_terminate_build 0
+Name: python-djangorestframework-link-header-pagination
+Version: 0.1.1
+Release: 1
+Summary: Provide pagination using a "Link" HTTP header as described in https://developer.github.com/guides/traversing-with-pagination/
+License: BSD
+URL: https://github.com/tbeadle/django-rest-framework-link-header-pagination
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/47/38/5a7129c5c7d022977868396d14313b7cd73ebf0027651ccc119093ecdf98/djangorestframework-link-header-pagination-0.1.1.tar.gz
+BuildArch: noarch
+
+
+%description
+
+
+%package -n python3-djangorestframework-link-header-pagination
+Summary: Provide pagination using a "Link" HTTP header as described in https://developer.github.com/guides/traversing-with-pagination/
+Provides: python-djangorestframework-link-header-pagination
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-djangorestframework-link-header-pagination
+
+
+%package help
+Summary: Development documents and examples for djangorestframework-link-header-pagination
+Provides: python3-djangorestframework-link-header-pagination-doc
+%description help
+
+
+%prep
+%autosetup -n djangorestframework-link-header-pagination-0.1.1
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-djangorestframework-link-header-pagination -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Fri May 05 2023 Python_Bot <Python_Bot@openeuler.org> - 0.1.1-1
+- Package Spec generated