summaryrefslogtreecommitdiff
path: root/python-djangowind.spec
diff options
context:
space:
mode:
authorCoprDistGit <infra@openeuler.org>2023-05-05 15:33:25 +0000
committerCoprDistGit <infra@openeuler.org>2023-05-05 15:33:25 +0000
commit0767945f3751b4716a0e110528f46133b0a99e8b (patch)
tree784070d4c56b53b17449f23bdca6c3df68524896 /python-djangowind.spec
parent26aa6363ae970b9be1ddc7b8b7da98f226b59f01 (diff)
automatic import of python-djangowindopeneuler20.03
Diffstat (limited to 'python-djangowind.spec')
-rw-r--r--python-djangowind.spec75
1 files changed, 75 insertions, 0 deletions
diff --git a/python-djangowind.spec b/python-djangowind.spec
new file mode 100644
index 0000000..169cd8a
--- /dev/null
+++ b/python-djangowind.spec
@@ -0,0 +1,75 @@
+%global _empty_manifest_terminate_build 0
+Name: python-djangowind
+Version: 1.2.5
+Release: 1
+Summary: Django Authentication backend for CAS
+License: BSD
+URL: https://github.com/ccnmtl/djangowind
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/f9/a7/95e129197ece09d0e8e9d7abda1c68781e989d2be13f6756526a190867fb/djangowind-1.2.5.tar.gz
+BuildArch: noarch
+
+
+%description
+Django Authentication backend for CAS and associated helpers
+
+
+%package -n python3-djangowind
+Summary: Django Authentication backend for CAS
+Provides: python-djangowind
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-djangowind
+Django Authentication backend for CAS and associated helpers
+
+
+%package help
+Summary: Development documents and examples for djangowind
+Provides: python3-djangowind-doc
+%description help
+Django Authentication backend for CAS and associated helpers
+
+
+%prep
+%autosetup -n djangowind-1.2.5
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-djangowind -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Fri May 05 2023 Python_Bot <Python_Bot@openeuler.org> - 1.2.5-1
+- Package Spec generated