summaryrefslogtreecommitdiff
path: root/python-drf-haystack.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-drf-haystack.spec')
-rw-r--r--python-drf-haystack.spec85
1 files changed, 85 insertions, 0 deletions
diff --git a/python-drf-haystack.spec b/python-drf-haystack.spec
new file mode 100644
index 0000000..db62e3e
--- /dev/null
+++ b/python-drf-haystack.spec
@@ -0,0 +1,85 @@
+%global _empty_manifest_terminate_build 0
+Name: python-drf-haystack
+Version: 1.8.11
+Release: 1
+Summary: Makes Haystack play nice with Django REST Framework
+License: MIT License
+URL: https://github.com/rhblind/drf-haystack
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/4a/65/579090f5b9c0dbe733fa3098844ec848c89c94231899a04952372b58a580/drf-haystack-1.8.11.tar.gz
+BuildArch: noarch
+
+Requires: python3-Django
+Requires: python3-djangorestframework
+Requires: python3-django-haystack
+Requires: python3-dateutil
+
+%description
+Implements a ViewSet, FiltersBackends and Serializers in order to play nice with Haystack.
+
+
+
+
+%package -n python3-drf-haystack
+Summary: Makes Haystack play nice with Django REST Framework
+Provides: python-drf-haystack
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-drf-haystack
+Implements a ViewSet, FiltersBackends and Serializers in order to play nice with Haystack.
+
+
+
+
+%package help
+Summary: Development documents and examples for drf-haystack
+Provides: python3-drf-haystack-doc
+%description help
+Implements a ViewSet, FiltersBackends and Serializers in order to play nice with Haystack.
+
+
+
+
+%prep
+%autosetup -n drf-haystack-1.8.11
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-drf-haystack -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Wed Apr 12 2023 Python_Bot <Python_Bot@openeuler.org> - 1.8.11-1
+- Package Spec generated