summaryrefslogtreecommitdiff
path: root/python-drkns.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-drkns.spec')
-rw-r--r--python-drkns.spec84
1 files changed, 84 insertions, 0 deletions
diff --git a/python-drkns.spec b/python-drkns.spec
new file mode 100644
index 0000000..17b0bba
--- /dev/null
+++ b/python-drkns.spec
@@ -0,0 +1,84 @@
+%global _empty_manifest_terminate_build 0
+Name: python-drkns
+Version: 3.0.6
+Release: 1
+Summary: Simple and agnostic monorepo build tool
+License: MIT
+URL: https://github.com/frantzmiccoli/drkns
+Source0: https://mirrors.aliyun.com/pypi/web/packages/52/3e/2e024407fed13d12c48aeaf4ef6abee753d132a07a32229de54d2833a5da/drkns-3.0.6.tar.gz
+BuildArch: noarch
+
+Requires: python3-awscli
+Requires: python3-dirhash
+Requires: python3-PyYAML
+
+%description
+Monorepositories contain many projects, it rarely makes sense to
+rebuild an every projects when changes are committed.
+But we can't build necessarily limit ourselves to run builds and tests
+in directories where changes occurred because some projects depends on others.
+
+%package -n python3-drkns
+Summary: Simple and agnostic monorepo build tool
+Provides: python-drkns
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-drkns
+Monorepositories contain many projects, it rarely makes sense to
+rebuild an every projects when changes are committed.
+But we can't build necessarily limit ourselves to run builds and tests
+in directories where changes occurred because some projects depends on others.
+
+%package help
+Summary: Development documents and examples for drkns
+Provides: python3-drkns-doc
+%description help
+Monorepositories contain many projects, it rarely makes sense to
+rebuild an every projects when changes are committed.
+But we can't build necessarily limit ourselves to run builds and tests
+in directories where changes occurred because some projects depends on others.
+
+%prep
+%autosetup -n drkns-3.0.6
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-drkns -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Tue Jun 20 2023 Python_Bot <Python_Bot@openeuler.org> - 3.0.6-1
+- Package Spec generated