summaryrefslogtreecommitdiff
path: root/python-embers.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-embers.spec')
-rw-r--r--python-embers.spec129
1 files changed, 129 insertions, 0 deletions
diff --git a/python-embers.spec b/python-embers.spec
new file mode 100644
index 0000000..a3cc0ca
--- /dev/null
+++ b/python-embers.spec
@@ -0,0 +1,129 @@
+%global _empty_manifest_terminate_build 0
+Name: python-embers
+Version: 1.0.0
+Release: 1
+Summary: Experimental Measurement of BEam Response with Satellites
+License: MIT
+URL: http://embers.readthedocs.io
+Source0: https://mirrors.aliyun.com/pypi/web/packages/0d/76/392a76493c2d6a70044fd3d666f46e5f9b808b161b10ef230e181981d973/embers-1.0.0.tar.gz
+BuildArch: noarch
+
+Requires: python3-astropy
+Requires: python3-certifi
+Requires: python3-chardet
+Requires: python3-cycler
+Requires: python3-healpy
+Requires: python3-h5py
+Requires: python3-idna
+Requires: python3-jplephem
+Requires: python3-kiwisolver
+Requires: python3-Logbook
+Requires: python3-matplotlib
+Requires: python3-mwa-pb
+Requires: python3-numpy
+Requires: python3-pandas
+Requires: python3-pyparsing
+Requires: python3-dateutil
+Requires: python3-pytz
+Requires: python3-ratelimiter
+Requires: python3-Represent
+Requires: python3-requests
+Requires: python3-scipy
+Requires: python3-seaborn
+Requires: python3-sgp4
+Requires: python3-six
+Requires: python3-skyfield
+Requires: python3-spacetrack
+Requires: python3-wget
+
+%description
+|PyPI| |ReadTheDocs| |Travis| |Coverage| |License| |Python| |Black|
+*EMBERS* is a pure-Python astronomy software package designed to enable polarised measurements of radio telescope antenna beam-patterns using satellites.
+*EMBERS* is designed to install cleanly with a single invocation of the standard Python package tool::
+ $ pip install embers
+Here are the essential project links:
+* `Home page and documentation <https://embers.readthedocs.io/en/latest/>`_
+* `Installing Embers <https://embers.readthedocs.io/en/latest/installation.html>`_
+* `Embers by Example <https://embers.readthedocs.io/en/latest/embersbyexample.html>`_
+* `Embers package <https://pypi.org/project/embers/>`_ on the Python Package Index
+* `Contributing to EMBERS <https://github.com/amanchokshi/EMBERS/blob/master/contrib.rst>`_
+* `Issue tracker <https://github.com/amanchokshi/EMBERS/issues>`_ on GitHub
+
+%package -n python3-embers
+Summary: Experimental Measurement of BEam Response with Satellites
+Provides: python-embers
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-embers
+|PyPI| |ReadTheDocs| |Travis| |Coverage| |License| |Python| |Black|
+*EMBERS* is a pure-Python astronomy software package designed to enable polarised measurements of radio telescope antenna beam-patterns using satellites.
+*EMBERS* is designed to install cleanly with a single invocation of the standard Python package tool::
+ $ pip install embers
+Here are the essential project links:
+* `Home page and documentation <https://embers.readthedocs.io/en/latest/>`_
+* `Installing Embers <https://embers.readthedocs.io/en/latest/installation.html>`_
+* `Embers by Example <https://embers.readthedocs.io/en/latest/embersbyexample.html>`_
+* `Embers package <https://pypi.org/project/embers/>`_ on the Python Package Index
+* `Contributing to EMBERS <https://github.com/amanchokshi/EMBERS/blob/master/contrib.rst>`_
+* `Issue tracker <https://github.com/amanchokshi/EMBERS/issues>`_ on GitHub
+
+%package help
+Summary: Development documents and examples for embers
+Provides: python3-embers-doc
+%description help
+|PyPI| |ReadTheDocs| |Travis| |Coverage| |License| |Python| |Black|
+*EMBERS* is a pure-Python astronomy software package designed to enable polarised measurements of radio telescope antenna beam-patterns using satellites.
+*EMBERS* is designed to install cleanly with a single invocation of the standard Python package tool::
+ $ pip install embers
+Here are the essential project links:
+* `Home page and documentation <https://embers.readthedocs.io/en/latest/>`_
+* `Installing Embers <https://embers.readthedocs.io/en/latest/installation.html>`_
+* `Embers by Example <https://embers.readthedocs.io/en/latest/embersbyexample.html>`_
+* `Embers package <https://pypi.org/project/embers/>`_ on the Python Package Index
+* `Contributing to EMBERS <https://github.com/amanchokshi/EMBERS/blob/master/contrib.rst>`_
+* `Issue tracker <https://github.com/amanchokshi/EMBERS/issues>`_ on GitHub
+
+%prep
+%autosetup -n embers-1.0.0
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-embers -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Tue Jun 20 2023 Python_Bot <Python_Bot@openeuler.org> - 1.0.0-1
+- Package Spec generated