summaryrefslogtreecommitdiff
path: root/python-et-micc-build.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-et-micc-build.spec')
-rw-r--r--python-et-micc-build.spec75
1 files changed, 75 insertions, 0 deletions
diff --git a/python-et-micc-build.spec b/python-et-micc-build.spec
new file mode 100644
index 0000000..8c1a1f1
--- /dev/null
+++ b/python-et-micc-build.spec
@@ -0,0 +1,75 @@
+%global _empty_manifest_terminate_build 0
+Name: python-et-micc-build
+Version: 1.1.8
+Release: 1
+Summary: CLI micc-build and module for building binary extensions created with micc.
+License: MIT
+URL: https://github.com/etijskens/et-micc-build
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/64/ee/6ea460dd02d4175920b92b7240157490a7bd22f4940690391598362c7d78/et-micc-build-1.1.8.tar.gz
+BuildArch: noarch
+
+Requires: python3-numpy
+Requires: python3-et-micc
+Requires: python3-pybind11
+
+%description
+
+
+%package -n python3-et-micc-build
+Summary: CLI micc-build and module for building binary extensions created with micc.
+Provides: python-et-micc-build
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-et-micc-build
+
+
+%package help
+Summary: Development documents and examples for et-micc-build
+Provides: python3-et-micc-build-doc
+%description help
+
+
+%prep
+%autosetup -n et-micc-build-1.1.8
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-et-micc-build -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Wed May 10 2023 Python_Bot <Python_Bot@openeuler.org> - 1.1.8-1
+- Package Spec generated