summaryrefslogtreecommitdiff
path: root/python-eventhandler.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-eventhandler.spec')
-rw-r--r--python-eventhandler.spec96
1 files changed, 96 insertions, 0 deletions
diff --git a/python-eventhandler.spec b/python-eventhandler.spec
new file mode 100644
index 0000000..015b493
--- /dev/null
+++ b/python-eventhandler.spec
@@ -0,0 +1,96 @@
+%global _empty_manifest_terminate_build 0
+Name: python-eventhandler
+Version: 1.2.1
+Release: 1
+Summary: A simple and effective event handler class, based in callbacks for python 3
+License: MIT License
+URL: https://github.com/davidvicenteranz/eventhandler
+Source0: https://mirrors.aliyun.com/pypi/web/packages/72/24/20339462930de921a182c0c3aa556c46308e5bf3eea3d9033f08f4233151/eventhandler-1.2.1.tar.gz
+BuildArch: noarch
+
+
+%description
+Is a simple and effective event handler class, based in callbacks for python 3
+''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''
+eventhandler
+~~~~~~~~~~~~
+Is a **python simple and effective event handler class**, based in callbacks for python 3.
+Build Status:
+~~~~~~~~~~~~~
+| |Build Status| |Coverage Status| |Pypi| |Python package and publish|
+**Github code and samples** https://github.com/davidvicenteranz/eventhandler
+
+%package -n python3-eventhandler
+Summary: A simple and effective event handler class, based in callbacks for python 3
+Provides: python-eventhandler
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-eventhandler
+Is a simple and effective event handler class, based in callbacks for python 3
+''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''
+eventhandler
+~~~~~~~~~~~~
+Is a **python simple and effective event handler class**, based in callbacks for python 3.
+Build Status:
+~~~~~~~~~~~~~
+| |Build Status| |Coverage Status| |Pypi| |Python package and publish|
+**Github code and samples** https://github.com/davidvicenteranz/eventhandler
+
+%package help
+Summary: Development documents and examples for eventhandler
+Provides: python3-eventhandler-doc
+%description help
+Is a simple and effective event handler class, based in callbacks for python 3
+''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''
+eventhandler
+~~~~~~~~~~~~
+Is a **python simple and effective event handler class**, based in callbacks for python 3.
+Build Status:
+~~~~~~~~~~~~~
+| |Build Status| |Coverage Status| |Pypi| |Python package and publish|
+**Github code and samples** https://github.com/davidvicenteranz/eventhandler
+
+%prep
+%autosetup -n eventhandler-1.2.1
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-eventhandler -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Tue Jun 20 2023 Python_Bot <Python_Bot@openeuler.org> - 1.2.1-1
+- Package Spec generated