summaryrefslogtreecommitdiff
path: root/python-evmdasm.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-evmdasm.spec')
-rw-r--r--python-evmdasm.spec162
1 files changed, 162 insertions, 0 deletions
diff --git a/python-evmdasm.spec b/python-evmdasm.spec
new file mode 100644
index 0000000..96a5867
--- /dev/null
+++ b/python-evmdasm.spec
@@ -0,0 +1,162 @@
+%global _empty_manifest_terminate_build 0
+Name: python-evmdasm
+Version: 0.1.10
+Release: 1
+Summary: A lightweight ethereum evm bytecode asm instruction registry and disassembler library.
+License: GPLv2
+URL: https://github.com/tintinweb/evmdasm
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/00/c4/2c782594450eac176ca0785904245979a7c0ecd3a96e65781a192f6b5765/evmdasm-0.1.10.tar.gz
+BuildArch: noarch
+
+
+%description
+[![Build Status](https://api.travis-ci.org/tintinweb/evmdasm.svg?branch=master)](https://travis-ci.org/tintinweb/evmdasm/)
+
+# evmdasm
+*A lightweight ethereum evm bytecode instruction registry, disassembler and evmcode manipulation library.*
+
+This library is meant for providing a static interface and registry for EVM opcodes and instructions. The idea is to keep it as lightweight as possible especially when it comes to dependencies or high level features.
+
+e.g. The [ethereum-dasm](https://github.com/tintinweb/ethereum-dasm) project - a kind of high level disassembler with static/dynamic analysis features - relies on the registry and base disassembling functionality provided by [evmdasm](https://github.com/tintinweb/evmdasm).
+
+
+**More information** --> **[Wiki](https://github.com/tintinweb/evmdasm/wiki)**
+
+Projects building on [evmdasm](https://github.com/tintinweb/evmdasm/):
+* :trophy: https://github.com/ethereum/evmlab
+* :trophy: https://github.com/tintinweb/ethereum-dasm
+* :trophy: https://github.com/tintinweb/evmcodegen
+
+### Setup
+
+##### from pypi
+```
+#> python3 -m pip install evmdasm
+```
+
+##### from source
+```
+#> python3 setup.py install
+```
+
+
+
+
+%package -n python3-evmdasm
+Summary: A lightweight ethereum evm bytecode asm instruction registry and disassembler library.
+Provides: python-evmdasm
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-evmdasm
+[![Build Status](https://api.travis-ci.org/tintinweb/evmdasm.svg?branch=master)](https://travis-ci.org/tintinweb/evmdasm/)
+
+# evmdasm
+*A lightweight ethereum evm bytecode instruction registry, disassembler and evmcode manipulation library.*
+
+This library is meant for providing a static interface and registry for EVM opcodes and instructions. The idea is to keep it as lightweight as possible especially when it comes to dependencies or high level features.
+
+e.g. The [ethereum-dasm](https://github.com/tintinweb/ethereum-dasm) project - a kind of high level disassembler with static/dynamic analysis features - relies on the registry and base disassembling functionality provided by [evmdasm](https://github.com/tintinweb/evmdasm).
+
+
+**More information** --> **[Wiki](https://github.com/tintinweb/evmdasm/wiki)**
+
+Projects building on [evmdasm](https://github.com/tintinweb/evmdasm/):
+* :trophy: https://github.com/ethereum/evmlab
+* :trophy: https://github.com/tintinweb/ethereum-dasm
+* :trophy: https://github.com/tintinweb/evmcodegen
+
+### Setup
+
+##### from pypi
+```
+#> python3 -m pip install evmdasm
+```
+
+##### from source
+```
+#> python3 setup.py install
+```
+
+
+
+
+%package help
+Summary: Development documents and examples for evmdasm
+Provides: python3-evmdasm-doc
+%description help
+[![Build Status](https://api.travis-ci.org/tintinweb/evmdasm.svg?branch=master)](https://travis-ci.org/tintinweb/evmdasm/)
+
+# evmdasm
+*A lightweight ethereum evm bytecode instruction registry, disassembler and evmcode manipulation library.*
+
+This library is meant for providing a static interface and registry for EVM opcodes and instructions. The idea is to keep it as lightweight as possible especially when it comes to dependencies or high level features.
+
+e.g. The [ethereum-dasm](https://github.com/tintinweb/ethereum-dasm) project - a kind of high level disassembler with static/dynamic analysis features - relies on the registry and base disassembling functionality provided by [evmdasm](https://github.com/tintinweb/evmdasm).
+
+
+**More information** --> **[Wiki](https://github.com/tintinweb/evmdasm/wiki)**
+
+Projects building on [evmdasm](https://github.com/tintinweb/evmdasm/):
+* :trophy: https://github.com/ethereum/evmlab
+* :trophy: https://github.com/tintinweb/ethereum-dasm
+* :trophy: https://github.com/tintinweb/evmcodegen
+
+### Setup
+
+##### from pypi
+```
+#> python3 -m pip install evmdasm
+```
+
+##### from source
+```
+#> python3 setup.py install
+```
+
+
+
+
+%prep
+%autosetup -n evmdasm-0.1.10
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-evmdasm -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Fri May 05 2023 Python_Bot <Python_Bot@openeuler.org> - 0.1.10-1
+- Package Spec generated